Cubase plays everything like it's midi channel 1

I set an instrument channel up with Sampletank 4,loaded an instrument into channel 10 of ST which is assigned to midi channel 10.
I also set the midi input channel on my Impulse in Cubase to channel 10.
My Impulse hardware is set so that the piano KB plays on Midi channel 1 and the drumpads play on midi channel 10.

Now When I play the piano KB,it makes sound which it shouldn’t.

I did this exact same test in REaper and REaper behaved as it should,no sound from the piano KB on midi channel 1 and sound from the drumpads on midi channel 10.

i did the exact same test in Cakewalk and once again Cakewalk behaved properly,no sound on midi channel 1.

Cubase seems to be the only DAW that plays Vsti’s assigned to midi channel 10 on midi channel 1.

Anyone have a clue on how to fix this?

Try switching the input channel of your Instrument track to “Any”.


TY Johnny ,that was it.

Actually that does not control the Input Channel, it controls the playback channel. If you were to open the recorded MIDI Part in the Key Editor and look at the individual Notes you’d find they are on Channel 10. When the Track is set to a specific Channel number all the Notes will be converted to that Channel during playback. But if you set it to Any it will play the notes on their actual Channel

1 Like

All a bit confusing to me.
I just thought the logical thing would be to set the input midi channel number and then it plays on that channel like Reaper and Cakewalk do.

By setting to ANY,it behaved the same as those Daws.

Cubase is a complicated beast.

I’m a bit of an outlier with this stuff,maybe I jumped too far in the deep end of the pool.

You have to be Einstein to make music these days.