Cubase Pro 10-5 activation on new cpu

Hello everyone,
I was using Cubase Pro 10.5 on an old Mac and it was time to upgrade the Mac. Now I’m trying to reactivate Cubase and I’m running into big problems that Steinberg’s FAQs don’t answer.

  1. “My eLicenser is already registered by another user”- yeah, I know. The other user is me. I can’t get Steinberg to register the dongle-based licenser.
  2. Without my eLicenser being recognized and registered. I can’t request a new activation code for Cubase. Obviously, the original activation code has been used on the first Mac.

I’ve tried everything that Steinberg has suggested: Uninstalling and reinstalling the License Control Center, updating everything possible, and emailing their support team (that hasn’t responded in 2 weeks).

Please help! I run a small recording studio, and everything revolves around Cubase working on this new Mac.

You cannot reactivate a license on the USB-eLicenser. Once it is there, it is “there”.

When you open the eLCC with your dongle plugged in, is your Cubase Pro 10.5 license displayed properly? If so, there is nothing else you need to do.

What happens when you try to launch Cubase? Does it open? Does it throw up a licensing error?

Are you saying that your license is not showing up in your MySteinberg account? If so, that would be a registration problem rather than an activation problem (I think?).

If you were successfully using the software with the dongle previously, there is no reason it shouldn’t work now (except the possibility of a malfunctioning USB-eLicencer).

My licenser says “This Full license allows you to use the product for an unlimited time period” so I’ve got the license, but here’s a dumb question: I did a complete backup of my old Mac and it brought over the Cubase 6 software but not 10.5 Pro. I don’t even have an application to launch 10.5 Pro. How can I go about getting the application? Please assume I’m an idiot with all of this (because I am).


Cubase Pro license is stored on the USB-eLicenser. You don’t have to do anything more but plug the USB-eLicenser with the license in.

That’s all I did. When I plug the USB-eLincenser in, I can’t find an option to launch Cubase. I’m probably missing something very easy, but either way I’m missing it.

It is available from the Steinberg Download Assistant.

That’s what I was looking for! I’m back online! Thank you MVP!

1 Like