Cubase Pro 10.5 and Behringer UMC1820 issue

I’m running C10.5 Pro on Win10

I just upgraded from a Behringer U-Phoria UMC404HD to a UMC1820. I’m having a problem with Cubase seeing it. It was only seeing generic drivers. When I click on the lower right windows Vol icon it correctly shows the Behringer outs 1-2. However when I open a session the I/O only shows generic device I/O. I checked out all the Windows sound device preferences and it all looks good…I have installed the latest drivers from Behringer.
What am I missing??


I would recommend to use ASIO4All driver.

Howdy, I’m not familiar with that one?
I actually had it partially working last week and Cubase saw it and all the I/O preferences were set up perfectly… but I couldn’t get sound. So I uninstalled the software and switched back to the UMC404, and it worked perfectly. Tonight I tried it again and got sound working, but now the I/O isn’t seeing it.
I’ve always been told to use the manufacture’s drivers. I’ll look into ASIO4ALL driver.

The trouble is asio4all is not a great driver. You are much better with the native driver for your hardware.

And 4hrs later, I figured it out :grin:. Thought I had covered everything. I missed two important preferences. There was one sub menu Windows setting under sound device, and one driver preference in Cubase(it’s late and I’m getting delirious! :woozy_face: ). Also had to reboot a couple times. This new UMC 1820 with latest drivers is a little more finicky than the old UMC404HD.
But all is well now…but too late to test with drum recording! :sleeping:

Glad you got it sorted :+1:


Unfortunately this is not true for many HW vendors. ASIO4ALL is not the best Asio Driver at all, but some HW vendors are producing even worse drivers. Sorry…

Congratulations! :slight_smile: