Cubase Pro 10.5 - No Valid Waves License Found

I cannot launch Cubase Pro 10.5 as I repeatedly get the error “No Valid Waves License Found”. Clicking “Skip” causes Cubase to close. I seem not to have anything called “Waves Central” anywhere on my system, so cannot run it to ‘rescan licenses’. I have only had this since upgrading from 10.0.5 (which ran fine - as did 9.5).

I’m assuming Waves is a VST plugin, but have never purchased it or installed a demo - so why am I getting this error?

Did you buy the 10 to 10.5 upgrade? It is not free!

I have been a Cubase user since before SX days - yes - I bought the upgrade. My question is not related to a license for Cubase - it’s to do with licenses for plugins.

I have now downloaded and installed Waves Central. No plugins were listed, but there was an option to uninstall V10 and V11 versions (generic selection - no actual plugin names - I can only assume that some time in the past I DID have some) so I ran that - which said it completed successfully.

Now Cubase gets as far as “Initializing: VST 2.x Plugin Manager” then quits silently after a few seconds…

[edit]
I uninstalled and reinstalled Cubase Pro 10.5 to no effect. It got as far as checking VST 2.x plugins then quit without an error message.

I then renamed every VST2 plugin folder by adding “_OLD” to it - and Cubase loaded and ran.

Whilst my memory might be a bit hazy on whether I ever installed/tried a Waves plugin in the past - I DEFINITELY have not changed my plugins setup between 10.0.5 and 10.5. I realise that this error is dependent on what plugins a user has installed (all my plugins are 64bit btw), but am I the only one having the problem?

After removing all plugins from “C:\Program Files\Steinberg\VSTPlugins” and putting them back one by one, the issue is with “Groove Agent” (v4). I have no idea how to fix it - but at least Cubase now loads and runs.

[edit2]
It seems my version of Groove Agent 4 was out of date and needed updating from v4.2.0.19 to v4.2.40.332. A clue to the problem (via the software) would have been helpful rather than it shutting down at every launch without a message…

So it seems that when I upgraded a piece of hardware on my computer (USB adapter) my Windows ID was changed. Therefore all the Waves plugins I had were now activated to my previous Windows ID and now not showing up in my DAW. FIX: Open Waves Central - click the Licenses tab - click the Disconnected Devices tab - there you will see all your licenses - select and move to My License Cloud - click My License Cloud and select and Activate to your computer - click the Connected Devices tab and you’ll see them in there now *Note that Waves allows you to move your licenses only once per year