Cubase Pro11 Stuck at Startup - Content License Check

Can anyone help or point me in the right direction, please? Since yesterday Cubase has gotten stuck on startup after getting to Content License Check 21 of 69. For all the previous steps of startup it was fast but then slows down once it gets to the Content License Check part, and as stated before - it freezes at check 21.

I tried to start Cubase with Safemode - deactivated 3rd party plugins + disabled program preferences , I’ve removed and then plugged the usb e-licensor back in, updated Pro11 to 11.04.1 and then performed maintenance check on the e-licenser control - and none of these things have worked.

The only change from yesterday to today, is I’ve changed locations and I’m now using a different internet network, but surely that has no relevance to the problem?

Many thanks

Cubase Pro 11.04.1
MacBook Pro 2016
Mojave 10.14.6


Could you try to plug the USB-eLicneser to other USB port, please?

Or could you try to reinstall the Cubase’s Content?

Thanks for the reply, Martin. I tried both those suggestions but with no success.

However, I have found a solution. Realizing that it must be Steinberg plug-ins, I removed ones that I don’t use from the Steinberg Library Manager. When I tried again, it worked!

I still don’t understand why this suddenly stopped working but I’m relieved that I found a solution.