Cubase quantizes to the wrong grid value (MIDI)

Issue: select MIDI notes in an event. When clicking on Apply Quantize, some of these notes do not quantize to the nearest grid value which defeats this Quantize button purpose.

See: https://youtu.be/dGsC7dufaCo

This is not the first this happens to me with Cubase. It also happened randomly on a different computer with Cubase 6 (my previous version).

Maybe I missing something obvious, but the grid type is correct and Quantize settings seem to be in order.

use the settings on the left to get better results

https://steinberg.help/cubase_pro/v11/en/cubase_nuendo/topics/quantizing_midi_audio/quantizing_midi_audio_c.html

you can edit a some parameters to change the behavior

Thanks, but I’m not sure to understand what you’re talking about. I may be blind but I cannot see “settings on the left” in the page you linked.

Also, I would like to specify that the Grid is set to Use Quantize and not Adjust to Zoom as seen here:
Screenshot-2021-06-12-164621

Apply “Freeze MIDI Quantize” first.

//
Quantize function is non-destructive. It is based on the original event positions.

Reset Quantize
Reverts your audio or MIDI to its original, unquantized state, and resets any length changes that you performed in the Quantize Panel.

Freeze MIDI Quantize
Makes the start and end positions of MIDI events permanent. This function is useful in situations where you want to quantize a second time, based on the current quantized positions rather than the original positions.

Quantize is non-destructive