Cubase: Recorded track is displayed ahead of bars

Hi, people!

I’ve stuck with this weird issue, though I’ve been using Cubase for quite a while.

I have attached screenshot with my project’s tracks.
The top one shown as it was recorded, the middle one is moved to match the beat, and the lower one is a drum beat just for clarity.
Though I am capable of playing guitar I highly doubt that I can consistently go ahead of the beat. I am not that good on guitar yet. So for me, it looks like Cubase moves that a bit forward for and I can’t get why. Any suggestions?
One possible hint: this is not happening when I enable direct monitoring for ASIO. But I definitely what to use some VST plugins while recording, that worked for me in the past.

My set up is:
Cubase5 portable
ASIO driver
RME babyface

Something to try…

Take a look in the VST Audio System menu to see if ASIO Guard is enabled. Then try the different available settings. Try it with it on/off, change the ASIO guard level settings, change the audio priority levels, & enable/disable the adjust for record latency setting.

If nothing there helps try using the “Track Delay” function that is available in the inspector. You can adjust time issues there +/- a chosen milliseconds of time. If certain VSTs effects are always off the same amount of time, you could set up your templates to have the adjustments already set.

I don’t have timing issues on audio tracks because I almost always record audio dry then add the VST effects afterwards. But, I do see timing errors on Instrument tracks using certain VST instruments. Concequently I do have my templates setup with a track delay setting saved for those VSTi instrument tracks that have historically needed it.

Regards :sunglasses:

I have this exact issue with both of my Apollo interfaces. It started with Cubase 9.5, on CUbase Pro 10 now. I have been with Cubase since SX3 and NEVER had this issue.
I have hat to go back to Pro-tools to record. NO ONE can tell me how to fix this. Would love to see if anyone could help. :angry:

Just wondering why you have your ASIO Guard level set to “High” and your ASIO Priority level set to “Boost”? I see you midi recorded (maybe on an instrument track?). I ask this because the CB manual specifically states that the “Audio Priority” should be set to “Normal” (for Windows only). Maybe this setting applies to you but I don’t know for sure because you did not report it in your post.

So, at a minimum, you should set it to the setting mentioned in the Op Manual. If that doesn’t help, try different settings as I previously mentioned.

Also… make sure your AI drivers are up to date.

Regards :sunglasses:

Thanks so much. Yes all my drivers are up to date. I have tried every setting from boost to normal on the ASIO.
I got a reply from Steinberg telling me that I have done every thing I could and that they might have to elevate the issue to the development team.
In the meantime I’m back to recording with Protools (which has no issues with my current Apollo setup).

Steinberg? Please… I do not Like ProTools.

I am having the same issue, using Cubase 10 Pro. It’s only happening when I open tracks I created months ago and now want to record vocals, when I play them back they are 1 second ahead of where the beat starts, no matter if I delete the old vocals channel and add a new one. Interesting thing tho, when I create a full new project and record, everything is fine. It’s only happening on older projects.

Had the same issue. Steinberg has not helped and basically ignored this.
UA gave me this work around. It works great.
You basically create a virtual send and route your mix when you record through it.

Hope this helps until Steinberg steps up.

This probelm has gone away since I upgraded to 10.5. Early days, will have to see if it’s cleared on all the tracks I was experiencing the problem on.