Cubase Recording Pre-count!

Hello everyone, so I mapped my MPK61 to Cubase 9 (elements) and am now able to play/stop/forward/rewind/record all from my controller. My issue is that I have my pre-count click set to be activated when I press record, when I press record on my midi controller it will begin recording BEFORE my start point.

In other words, it records before the pre-count finishes thus sending me into a world a frustration because something so simple is being so difficult. Any one have an idea as to how I could fix this?

What’s even stranger is that last night everything worked fine, when I hit record it would count 1 2 3 4 then start recording no problem. At some point last night Cubase crashed and deleted all the mapping I had done. Everything is back the way it was but I am not getting the same results.

Thank you!

Do you have the pre-roll option activated?

On the Transport panel, activate pre-roll and set the pre-roll amount field to one bar (or other preference).

I just installed Cubase 10.5 and discovered that the precount function no longer works. Did you ever find a solution?

Yes, I have Precount clicked On in the transport panel.