Cubase refusing to play EZD2 sound library through my Vdrums

Hi. This is my first post here, and I’m a bit of a novice so bare with me here.

I’ve been using my Roland TD30K together with EzDrummer2 and Cubase 8 Elements (64) since 2016. Today, when after moving, I set up my TD30 as usual, connected the TD module to my computer via USB, launched Cubase ready to rehearse some tracks, so far so good.

Now, first off - when playing on the TD30 straight through the EZD2 launcher outside Cubase, the translation of the EZD2 sound libraries that I am using is working just fine, but when I start Cubase, they won’t work. I havn’t really changed settings since 2016, so I don’t really know what’s going on.

Cubase recognizes that the TD30 is plugged in, it records the midi signals when I hit the drums, but the sound that’s played in my headphones when I play on the TD30 are whatever current pre-set sounds from the TD30 module itself that I’m using instead of using the EZD2 plugin sound library. Although when i play the recorded track in Cubase, Cubase is playing the EZD2 sound library sounds. When I open the VST instrument tab and look on the drumset screen and hit any of the drums on my TD30, there is no reaction on the VST screen, BUT the “MIDI Out Activity”-bar in the Cubase control bar is bobbing, meaning it IS reacting to something. Also, note that previously, none of these things had to be checked whatsoever as it installed itself and translated EZD2 sounds automatically, but I’ve been going through all possible scenarios today (that I can think of at least) for the past few hours and I’m getting tired & mad. Here is a list of things that I’ve checked:

  • In the TD30 module under setup → MIDI, local control is set to OFF. As it should be, so as to prevent the drums from playing BOTH EZD2 samples AND the TD30 sounds simultaneously. - However doing this will result in complete silence instead of letting EZD2 act as the drumset.
  • I’ve toyed around with the other settings under the same tab on the TD30 module aswell, trying all sorts of combinations for MIDI In & USB MIDI, with no luck. If Local Control is set to off, it’s apparently set to off permanently and the drums won’t playback any sounds whatsoever.
  • In Cubase, the MIDI input is set to TD30.
  • The VST Instrument is set to EZDrummer2.
  • VST Audio Systems, set to TD30.
  • Under File - Preferences - MIDI, MIDI Thru Active is unchecked.
  • I’ve tried with monitor both ON, and OFF.
  • Updated all drivers for EZD2 and Cubase.

What have I missed? Why won’t Cubase recognize and playback EZD2 when I play on my E-kit?