Cubase Sampler "Set Sample End" bug

I opened a recent project I was working with, that had several Cubase Sampler tracks, and noticed that the samples weren’t being played back correctly. Every time a midi note triggered a sample, I would hear a really quick “click” that resembled the original sample a bit. Digging further I realized that the sampler started behaving as if the “Set Sample End” point was a short distance from the beginning of the sample, even though it was actually at the end at its default position. This bug only happens when the sampler is on “Solo” option within the “Warp” mode, as it was the case. I tried moving around the “Set Sample End” point, turning on and off “Warp”, reselecting the sample file, even duplicating the whole Sampler track and it didn’t fix the issue. Curiously I tried creating a new sampler track from scratch, loading exactly the same sample file, and setting all parameters to the exact same position as the “broken” sampler track, and it did sound ok. So I had two identical tracks, while one was functioning properly and the other was bugged. I can surely apply this solution to all my sampler tracks but believe me it would be a hassle. I produce electronic music and this track specifically abuses the sampler tracks, having almost 20 of them with all kinds of crazy plugin automation and routing and sidechain routing etc. Does any one have a clue on how to fix this besides the tedious manual way I described above?

Thanks a lot

I’m having exactly the same issue except I can’t even get new sampler tracks to work in “solo” mode.

Hoping someone out there (Steinberg?) has a fix…!



I’m having the same problem here as well.

On top of that, if I “back up” a project, the sampler tracks in the new project still reference the old audio files (despite copying the samples to the new audio folder too). If I trick Cubase to have to look to the new files (by renaming the old project folder and pointing the missing samples to the new audio pool), it will load but any Sampler Tracks using “Solo” mode won’t playback.

I think this has been a problem for at least a year. I really like the Sampler track and I would really like for this to get fixed.