Cubase sending random MIDI messages to Arduino Controller


I’ve made my own DIY Arduino MIDI controller, which uses loopMidi to create a virtual MIDI port and hairless-MIDI to convert Serial to MIDI and back.

And I can control the DAW with my DIY controller, no problem (it’s awesome :wink: ). But I want Cubase to tell my Arduino when it’s recording so my Arduino can turn on a red LED.

But Cubase just sends 127 and 0 randomly without me pressing the record button.
See image(screenshot) in the attachment for more details.

Have I set up the MIDI controller wrong in Cubase?

The GR sends the midi message assigned to the button in the top pane when the command is activated in Cubase. It works here.

To troubleshoot this

  • remove the Arduino device from the Generic Remote inputs and outputs and replace it with a midi monitor like the one in MIDI-OX. Assign only the output.
    What does Cubase send to the monitor?

You say you’re using LoopMidi? Rename the port so it corresponds to what’s displayed in the GR for troubleshooting, so your report corresponds to your examples.


I’ve installed MIDI-OX and linked it to a loopMidi-Port which is also an output of a GR.

MIXI-OX displays (see image):
00 [= 0]
7F [=127 I think]

So the problem hasn’t got anything to do with hairless-midi or my Arduino. It can only be Cubase or loopMidi.

Just check the images to see whether I’ve done everything correctly

If you check out the second screenshot, you’ll also see that my piano recording is full of some data, even though I didn’t even touch my piano.

Aha! Then that’s the problem!

I turn my keyboard off (and disconnect the inputs for my piano track) and it works!!!

My keyboard must be sending something back to Cubase every time it sends data to my GR

How can I stop this?

I’ve had a look at the data in the piano recording

It’s all modulation (cc1) if that helps

Here are some tips, hope they help.

You’re programming an interface, for which you need good troubleshooting skills which mainly consist of removing elements one at a time until the problem goes away. Your goal here is to find the source of the midi messages. You will need to know the basic MIDI message types, what is a status byte etc.

Temporarily remove all MIDI devices that are connected to your system

Configure MIDI-OX to display decimal instead of hex so you can understand the output.

Know what ports are open in MIDI-OX.

Use only one tool to monitor the output of the GR. You have the midi track input assigned to All Midi, delete the MIDI track or do un-assign any inputs or outputs to the track.

Great! I was typing while you posted.

Your keyboard is broken, probably, as it’'s sending mod wheel (cc1) messages on its own.

Oh Sorry! I was wrong! It still doesn’t work, even without the keyboard and the piano track

Also, change the command the GR sends out to be a Note rather than controller, for good measure

Ok. Changing GR to be a note made no difference. Also if you check out the screenshot(taken while it was recording) and look at the bottom right, there’s a constant midi input even though there are absolutely no midi inputs (all turn off in the midi settings and unplugged).
I’m still using loopMidi though. I don’t see a way of connecting MIDI-OX to Cubase without it. I tried MIDI-Yoke by the same guys but it doesn’t work on my PC (won’t install). Because MIDI-OX doesn’t act as a port, just as a monitor that reads data from a different port.

If there is midi input, something is sending to Cubase.

Create two ports in loopMidi - one for Cubase => Arduino and the other for Arduino => Cubase and make the necessary changes in Midi out/in both in Cubase and in hairless-MIDI.

Using one port in loopMidi is like using one Midi cable to connect all Midi Ins/Outs - you short circuit the whole thing and create Midi loops.

THANKS!!! It works! :smiley: :laughing: