Cubase slowing down

As I am working on various projects, Cubase slows down and down. I would blame it on lack of system resources, but my system has 8gig RAM, 3.2 hex core CPU, and a 6870 GFX card with 1 gig Video RAM.

When a lot of plug-ins are loaded, it becomes slower, key strokes are slower to respond to, I get the odd glitch in playback, and the GUI jumps from time to time.

I thought it was down to plug-ins ,but I removed the problem makers and it was all back to normal, it’s just when a project gets loaded up, full of plug-ins, Cubase suffers. Is this a problem with my setup ? The ASIO meter is at about 20% if that. CPU use in the task manager is about the same during playback, a bit more maybe.

I dunno why it’s getting so slow. Is it a known problem that it does slow up with the heavier loaded projects ? Can I optimize Cubase in anyway ?

Hello,

which Cubase version do you have exactly ?

Please keep in mind that it costs allot of resources when you have allot of plugin GUI’s opened. Not every developer takes care in that area about the resources.

Cheers,

Chris

Hi,

It’s version 6.0.5 64bit, running on Windows 7 64bit.

Looking at task manager while a loaded projected is playing (Lots of plug-ins) CPU hits 40% maximum, RAM is up to 4gig total, out of a possible 8, the Cubase.exe using 1.5Gig.

The whole program just seems sluggish, which I find odd seeing as it’s got stacks of resources left at it’s disposal.

Are there any tweaks I can make to allocate more GPU to running the GUI etc ? I’d disable Aero if it was possible, dunno if that would help, problem with that is that you need to disable it globally it cannot be done per application.

Check all of your CPU cores are running. Also check the computer’s temperature. Risng heat level indicates something could be faulty or overloaded or something as simple as dust is slowing down the CPU fan.

Slowdown is almost always down to system components rather than software especially if the components are well adequate to run the software as looks the case here. Heat rise would confirm that to me aside from the case that something has stopped one or more of the CPU cores running where I would check all running apps.

OK thanks, well this is what I found.

All cores are showing 20-30% during playback in task manager, apart from core 5 which is up in the 60-70% area, I assume due to not all plug-ins being able to use multi-threading.

Temperatures wise:

CPU 37 degrees C

Graphics card 50 Degrees C

Chipset 34 degrees

Hard drive A 29 degrees

Hard drive B 33 degrees

Liquid cooler on the CPU and 8 case fans and I recently just cleaned them out too from all dust.

I just noticed when I made a save to the project, I had major system slow down, is this a disk problem ? Access times to and from the disk are too slow ? It’s a brand new 500Gig SATA 3 drive 6gig transfer, better than the one I had before. . .

Try splitting plug load on any heavily processed single channel by assigning to a group & placing half of them there…all plugs on a single channel will load the same core.
Also if you have instruments used multi-timbrally switching to separate instances for each patch can spread the load.

Oh & also make sure you have core parking disabled.

OK thank for the advice.

Core parking though, never heard of that, what is it ?

I’d recommend reading this thread: https://www.steinberg.net/forum/viewtopic.php?p=108775#p108833
and look for Hippo’s answer … btw google is your friend :sunglasses:
Take care,
B.

Do you have a bunch of edits, xfades, or time stretching going on? I notice Cubase reacting slowly when a bunch of real-time edits are being run. Bouncing heavily edited events can speed things up.

The most powerful system can be brought to its knees by too many plugins. And some of today’s plugins are very demanding. It might be interesting to see your list of what comprises “a lot”.

Hi Grim - can you please explain what you mean “switching to separate instances for each patch” for the multitimbral instruments? Are you suggesting if I have Halion Sonic SE going out on 8 channels to instead consider running 8 instances of HSSE going out on one channel each (or 4 on 2, etc.)?

To the OP - this happens to me too, and on projects none to big. It helps a bit if I freeze my plug-ins, and also if I CTRL-W/CTRL-Q. But it may be a different thing because my ASIO meter is averaging around 60-65% when this happens to me, much higher than you’ve noticed yours is.

Thanks -

I’m not convinced that the ASIO meter indicates anything terribly useful on multi-core multi-thread systems.

I can’t remember why right now, but I was advised to change from the Steinberg power management option to High Performance and then change advanced settings to make sure nothing “powers down” or doesn’t run at high values.

Core parking doesn’t apply with my processor apparantly, it only applies to the Opteron and Bulldozer chips, I am on PII.

My system is using 30-40% of it’s total resources in task manager, ASIO meter is showing around the same, yet the issue seems to be consistent.

I have globally disabled Aero, turned off various un-needed services (Windows search etc) problem remains, even though system feels faster. There are little or no background things going on at all, i’ve cut them down to the absolute bare minimum, with the running AV (Which I know can kill systems) is ESET, and i’ve never had this problem before. It’s since the C6 update, and I have a feeling it’s GUI related, since the GUI update, it’s not fully optimized.

As for how many plug-ins are running, off the top of my head, 10 synth vsti’s, 1 instance of Kontakt, and a lot of effects, well over 20 i’d suggest. I guess you’d not say that’s a lot , but it seems to be enough to cause the slow down. It’s not unusable, but i’m only halfway through this project, so the plug-in count could get a lot more.

Could be a bottleneck somewhere, but i’m not sure where that would be.

Hi Grim - can you please explain what you mean “switching to separate instances for each patch” for the multitimbral instruments? Are you suggesting if I have Halion Sonic SE going out on 8 channels to instead consider running 8 instances of HSSE going out on one channel each (or 4 on 2, etc.)?

Exactly that…it may seem counter intuitive but multitimbral instruments can soon bog you down because they don’t split the load over multi cores (AFAIK…not sure if there are any exceptions). As a quick test turning off your multi-timbral instrument/sample player while watching win task manager performance tab will show if the highest core use drops at all.

Regarding aero…according to many, disabling it can actually worsen performance so check carefully.

OK, I’ll check that out, thanks Grim.

Just as an aside, I found that it slowed down even though my VSTs were “frozen”. One of them is Jamstix3, which has to be frozen in the VST, not in Cubase. When I did that, the ASIO meter didn’t drop much … I wonder if it is not really being frozen in the usual sense …

Maybe it will get optimized again in the 6.5 update, it’s a brand new GUI it might be harder on the system than expected, or just needs tweaking.

Could be any number of things tbh.

Do you have all of the sends connected? (ie the option in the prefs that automatically connects sends to fx channels)

In my opinion it is some problem in routing, the more connections there are, the longer it takes for the system to respond.
With just a few tracks, the system is very snapy, but with 100+ stereo channel projects with many groups and fx busses, if you want to change anything in the routing, it takes very long and the program seems frozen when the actions is being performed. Most (but not all) plugins react exactly the same in the same scenario. Add, turn it off, turn it on… same thing. Bypass is problem free.

Well that certainly is true, the fewer channels Cubase is lightening quick, when there are quite a few, then it gets bogged down.

I didn’t even know there was an option to connect every send. I’ll disable it, see what happens.

I’ve managed to make it a bit more spritely by increasing the Disk Buffer size from 2 to 6 seconds (Disk Pre-load even)

That has apparantly taken the strain off the Disk streaming. So I am guessing the slow downs are the transfer between hard drive and PC, so there is a bottleneck, has to be.

BUT, hasn’t stopped the very very slow response from QWERTY keyboard and mouse clicks when trying to open things. I’m getting around it atm with macros to additional mouse buttons. It’s annoying though.