Cubase starts lagging after some time

Hi all

I have a rather annoying problem. I use Cubase 6.03 live on gigs, where I use a midi controller to control some vst’s (DiscoDSP, Legacy Cell, Wavestation and HALion sonic SE). Furthermore I have a lowpass and a highpass filter on the master insert and a delay plugin on the Legacy Cell channel.

Through automation a have made a setup that mutes or unmutes the different vst’s and also changes the programs when I select the next marker. All markers are named as the songs in our set, so all I have to to is to choose a marker and Cubase will change my sounds and I’m ready to play the song by just clicking one button on my controller. Oh yeah, almost forgot, I also have a arrangertrack setup, so I can make different sets by changing the arranger chain, in the same project file. It’s pretty great and used to work like a charm.

But reasently Cubase has started to “lag” at some point. Sometimes after only a few minutes after booting. What happens is that suddenly some serious latency-effect occours. Especially if I play many notes at the same time. If I hit a 3 or 4 note chord it will play the notes at very different times.
Also I can see the meters on the mixer in Cubase also start to be slobby and slow when this occours.

I’m pretty sure, that it’s not a buffer related problem, but I don’t have any idea as to what causes this. It’s something that just happened all of a sudden and I haven’t changed anything on the pc. It went from working to not working without me doing anything (that I’m aware of at least).

I’m running an audio optimized Vista 32bit on a 4GB Ram, 7400rpm HDD, 2,53 GHz Intel dual core. Asio4all driver.

The best solution so far is to restart Cubase, but that’s not optimal when playing a concert. :frowning:
Do you have any ideas as to what I can do? Is there anything that I should reinstall, update or anything?

Hello,

I can recomend:

  1. Windows 7, for which is Cubase 6 optimized, and which is supported
  2. Using high quality sound card, with own (and great) ASIO driver: Steinberg MR series, or RME is great choice!

Best,

I used Alesis IO|2 (with Asio4All) and now I use Focusrite Scarlett 2i2 (with it’s own dedicated asio driver).

Also it’s seems that I might have found a “solution”. If I hit play followed by stop, then the lagging dissappears. I gotta try this a couple of times to check, but it seems so…

Windows 7 would be great, but it’s just not an option at the moment.

Focusrite sound card have quite good pre-amps and converters, but unfortunately not driver.Focusrite drivers have quite big katency too, in my experience.

There is a bit more latency with the Focusrite driver, yes. But it’s not actual latency that is the problem.

I just tested the play/stop solution again. It worked again. Also I checked with the Windows system monitor to see if anything was pushing my machine too hard. There was nothing to see. Plenty af RAM still free, the CPU never came above 50% and the disk was at a steady 0-2%. There wasn’t any difference on the system usage before and after I pressed start/stop. this sort of makes it impossible for me to spot what the real problem is, so all I can do, is use the start/stop-solution.

Is there any sort of “sleep mode” or “energy saver” in Cubase 6 that activates after some time perhaps?

Not in Cubase. In the Windows, there is lots of functions like this. Did you switch off all of them?

Yes I have. As I wrote I’m running an audio optimized version of Vista. I bought my PC a couple of years ago at http://www.frostacm.com/ and they made a good job of optimizing both the computer and Vista.

And I just double checked today. Everything is set to maximum performance in Windows.

This sounds common to me! If I leave my Cubase “alone” for a while and start the playback, it takes a few seconds untill sound is back. If I stop, play again, it’s all ok again! I did not try to record MIDI but Audio after Cubase was active for some hours, in this situation I remarked it for the first time, audio recording was distorted. Stop & Play & Record and it was solved.

Maybe it is related to the MIDI Interface? I have Windows 64 Bit and a MIDEX 8 (SB driver available but unsupported, minor testing)…

Just a consideration…

That does sound a bit like the same thing…

Hmmm… I think I’ll try to test my setup on my other laptop. It’a a Win 7 64 bit, so if the same error occours, then I think we can rule out the Vista vs Win 7 in this particular case.