I recently began building a home studio and I’m running into major technical issues within Cubase 8, specifically regarding recording vocal tracks over my imported .wav files.

Just to make a short list of exactly what I’m working with, as far as my hardware/software:

Macbook Pro (Operating System: El Captain)
Maschine Mikro
Steinberg Audio Interface UR22 MkII
AKG P120 Microphone
Native Instruments (beat production)
Cubase 8

Basically, all I’m trying to do is create beats and music using Native Instruments and Maschine, which I’ve had no problems with thus far. I have created a few .wav files tracks that I am wanting to track vocals over.

I have successfully installed Cubase, all drivers and updates, and have no problems getting audio to pick up within Cubase. My issue is that when I drag and drop my .wav file into a channel within cubase, then try to record my vocals on a second channel while the music plays in the background, both the .wav file and my vocals are recorded at the same time. Essentially, when I try to record vocals, the music is being recorded for a second time in the vocal channel. The result I’m looking for is the ability to play the track through my headphones while I record my vocals without this happening. I want to be able to record JUST my voice, and not the music file. I can’t quite figure out how to route the channels correctly so that only my vocals are being recorded, while the .wav file track music is unrecorded. I have tried to mute the track and record only my vocals, which does work, but then I am unable to hear the music through my headphones, making it impossible to track vocals accurately.

Now, I’m assuming the issue lies in my VST device setup or my channel setup. If anyone can offer a solution, or help me troubleshoot this problem, I would greatly appreciate the help. Sorry in advance for being so ill informed and noobish. I’m new to this process and just need a little help. Thank you guys!

OK, quickly, off the top of my head, I would say you have an audio routing problem - the output of the backing track is getting to the input and being recorded again.

Check that you’re using the right driver (core audio, IIRC, as it’s a mac).

Check that you have your inputs and outputs set up correctly (I’d think Devices > VST connections), and ensure your input is appropriately - i.e. from UR22 input 1 for a mic if you have it plugged in there.

Check that you’ve not got anything external plugged in such as an output on the card going back to the input (yes, I’ve actually seen this!).

Check that there’s not something in the UR22’s settings that’s enabling the output audio to be looped back to the input (I know there’s some DSP on a UR44, not sure about the UR22).

See if changing the monitor mix control on the UR22 (front panel) makes a difference to whether or not the backing track gets recorded as you’re doing it - this may give you a clue as to whether this is a software/internal or hardware/external issue.

I’m pretty sure when you find out what it is you’ll have a “D’oh” moment, but without more straightforward info (maybe a pic of the setup?) it’s difficult to fault-find via a forum. It’s the kind of thing that would probably take 2 minutes in person!

That’ll be the one…Turn off loopback in the UR22.

1 Like

i please also need help with this exact issue except im making using of a windows 7. Please anybody that could me would be really appreciated

That’s true. It’s on dspMixFx_UR-C software. When we download this software, the problem might occur and you have to turn off the loopback first.