Cubase won't start

Hello there !
I just buy Cubase 9.5 and I’m very excited to use it :smiley: .
Unfortunatly, the software don’t want to start !
I think the problem is about my Graphic Cart, an old one :unamused: but I need to be sure of that before buying a new one !

All update are ok.

Wind 7
Intel Core i5-6600K
ASUS Z170 PRO
Corsair DDR4 16Go
Graphic cart : GTX460
Sound : UR22

If it’s about the graphic cart, I will buy an ASUS GeForce GTX 1050 Ti


What do you think ?
Thanks a lot !

Please take a look at this article:
https://helpcenter.steinberg.de/hc/en-us/articles/115001841510-Windows-Cubase-9-5-does-not-start-or-crashes

You probably just need to update your GeForce drivers. If that doesn’t work, try an older version of the drivers.

Hello there,
I’ve already tried both. The drivers are ok and older version are from 2006.
Sorry if my english is not perfect.

EDIT : Do you know where to found a list of compatibility Graphic cart/Cubase ?

The system requirements are listed here:
https://www.steinberg.net/en/products/cubase/resources.html

Any graphics card made in the past 10 years should work. The issue you’re having is very rare.

Go here to download newer GeForce drivers:
http://www.nvidia.com/Download/Find.aspx?lang=en-us

Try a bunch of different ones. It might help to restart your computer after installing each driver, before trying to run Cubase.

Thanks. I’m gonna make some test again and I will tell you. I just saw my Win 7 is not fully updated, maybe it’s because of that. I cross the fingers.

Well … GTX 470 is 8 years old.

Cubase ask for “Graphics card with DirectX 10 and WDDM 1.1 support (Windows only)”
Mine have DirectX 11, but I don’t know what WDDM 1.1 mean exactly.