Cubasis 3 3.2 MIDI Latency Build-up

Hi,

When using MIDI-Thru on a MIDI channel to play external MIDI instrument from external MIDI controller, a noticeable latency builds up after a few minutes. Closing Cubasis 3 and re-opening resolves the problem temporarily, but after a while the latency returns and a new shut-down and re-start is required. Very annoying.

Expected results: No latency on MIDI whatsoever at any time

Actual results: Noticeable MIDI latency builds up after a few minutes, making playing impossible. From investigations using headphones in various parts of my setup, it’s not an audio latency, it’s definitely a MIDI latency. The is issue temporarily resolved by shut-down and re-start the app, but only for a few minutes, after which the latency returns.

Hardware: iPad Air 3rd Gen (2019)
Audio/MIDI Interface: iConnectivity ConnectAUDIO 2/4 and Apple CCK

Software: iPadOS 14.3, Cubasis 3 V3.2, iConnectivity Firmware latest (V2.0.1)

I have set-up a template with 3 MIDI tracks each set to output to a different channel for each of my external gear, and I mute the ones I don’t want to hear. A single audio channel is used to hear the audio and apply effects/record as a start point for a project. The latency is apparent not only on the audio channel but also when I use headphones on the external gear being triggered by MIDI. Shutting down Cubasis 3 preserves the template exactly as it was when it re-starts, and for a few minutes at least the latency is gone, but it then builds up again. I searched before posting, the only thing I could find was to do with Cubasis 2 and an older iPadOS so not relevant.

Many thanks,

Marley

Hi marley909,

Thank you for your report, which has been shared with the team.

Do you achieve these results when working in cycle mode?
Does things work as expected, when cycle mode is disabled?

Thanks,
Lars

Hi Lars,

Thanks for getting back, I was beginning to lose hope.

Cycle mode is only to do with recording, right? The issue occurs when simply using Cubasis 3 as the “MIDI Hub”, i.e. playing a MIDI instrument via a MIDI controller with the iPad’s Audio/MIDI interface performing the MIDI THRU function. The idea with this is to be able to play around, come up with ideas or carry out some sound design, and be able to hit record whenever anything interesting happens, either MIDI, audio, or both, and build a track from there if the result merits it. Before recording, Cubasis 3 is simply in “stand-by”, reading and passing through the MIDI data on a MIDI channel, and monitoring the audio on an Audio channel. No plug-ins involved.

When Cubasis 3 first starts, MIDI latency is practically zero. As far as I can tell, the notes I hear are instantaneous to when I press the keys. But after a while in this “stand-by” state, a really noticeable latency builds up, making it basically unplayable. I mean a good fraction of a second, more than a 16th note, nearly as much as an 8th note of latency. The only remedy is to stop Cubasis 3 and re-start it, at which point the latency goes away again, only to return after a few minutes. It takes less than 5 minutes, I haven’t timed it. It grows gradually, gets more and more noticeable. I suspect it actually starts growing straight away, but it takes a few minutes for it to build up to the point where I can notice it.

Latency settings are at their minimum, I have tried various settings to try and get rid of it. I have also tried not only muting but disabling the MIDI input for the tracks I have set up for the other MIDI instruments that I am not using at that particular time, with no results.

For me it’s making Cubasis 3 unusable and I think I’m going to have to re-think my setup. I was going to ask for a full refund. I purchased it and all the available IAP’s in early Dec because of the 50% discount, so I’m keen to get a refund if you are unable to fix this.

I look forward to hearing from you!

Thanks,

Marley

Hi Marley,

Below please find additional feedback from our engineering:

Thank you for the additional info. Unfortunately, we cannot reproduce this issue, the latency is still perfect after playing 10 minutes on a Yamaha piano, connected via MIDI cable to a UR44C, connected via USB cable to an iPad, iOS 14.3, Cubasis 3.2.

Would it be possible to try some variations of the setup and provide us with more information? Here are our questions:

  1. Which devices are connected to the MIDI IN and OUT ports of your ConnectAUDIO 2/4 ?

  2. Does the issue occur if you delete the audio track?

  3. Does the issue occur if you connect a different MIDI controller (keyboard) to your ConnectAUDIO 2/4 ?

  4. Does the issue occur if you don’t use the ConnectAUDIO at all and directly connect any USB MIDI controller (keyboard)?

PS: Cycle mode is for playback and recording between the locators, but it sounds like you’re not even having playback running, which eliminates some causes already.

Best,
Lars

Hi Lars,

Thanks, it looks like a false alarm.

When I first noticed the issue, I was on iPadOS V13, with no MIDI plugins. After updating to V14, I did actually download and start playing with a MIDI plugin, and didn’t realise it was still in the channel.

After removing the MIDI plugin, I’m no longer experiencing the issue, so I can only assume it was causing the problem in V14, but some other issue was causing the same problem in V13 but was resolved in moving to V14.

You can close this now, thank you. I have started seeing another issue, clicks and pops on the audio channel, which are resolved by restarting Cubasis, but it’s only happened twice so far and it takes about half an hour to become apparent, and I haven’t played with the latency settings yet which are at the minimum. If I’m still having problems I will start another thread.

Thanks,

Marley

Hi marley909,

Thanks for the update.

Thanks, it looks like a false alarm.

Glad to read that the issue has been solved.

Thanks
Lars