Cubasis 3.4.1 available

Hi @Edward_Solis,

Thank you for your message and a warm welcome to the Cubasis forum.

Please give it a try to set “Latency” to 5 ms, enable “Multicore” and set “Guard Buffer” to “Default”.

Does this help to resolve the problem?

If so, you might give it a try to change settings back individually to see which to keep enabled/disabled etc.

Best wishes,