Cubasis 3 doesn't recognize Roland Go:Mixer pro reliably

I just canceled a planned recording because I ended up too frustrated with Cubasis. In Cubasis 2, I don’t recall ever having trouble connecting my Go:Mixer Pro via lightning. With CB3 I sometimes end up in a state where input keeps using the built in mic, and output uses the built-in headset port.

Are there any guidelines on how to avoid stuff like this? In which order do I do the following steps for best results?

  • start Cubasis 3
  • plug in Go:Mixer Pro
  • Turn on Go:Mixer Pro

Related feature request, maybe show a pop-over notification when a new audio interface is recognized, so the user at least knows something happened.

And to the coders, did anything change between CB2 and CB3 that could affect recognizing external hardware? I used to love recording in CB, but right now not so much!

Hi Pitchy,

Thanks you for your message.

Normally, Cubasis 3 support class-compliant devices same way as Cubasis 2.
Are the Cubasis input/ouput channels routed properly?

Unfortunately we are not equipped with Roland’s Go:Mixer.
However we’re at hand to have them equipped with Cubasis promo codes for testing purposes if required.


Hi Lars, thanks for the response. It seems like CB3 sometimes just doesn’t see the device when plugged in. Is there a best practice? Plug in before starting CB3, or start CB3 and then plug in the device? Or should that not make a difference?

As for input / output channels, where would you set that? In settings? In CB2 under settings > audio I could at least directly see which audio device is being used. In CB3 I don’t see anything like that. Could that be added back in?

Ideally I’d like to be able to use the external device as input, and the iPad headphone jack as output, which doesn’t seem to be possible either. When CB3 does detect the Go:Mixer Pro, it seems to auto select it as both input and output. Am I perhaps overlooking settings?

Hi Pitchy,

I’d suggest to get in touch with Roland about this.

We’re at hand to have them equipped with a Cubasis 3 promo code for testing purposes, if required.
In this case, please share their contact with me via private message.

Hope that helps.


You might be able to use AudioBus to pull that off.

Thanks, I haven’t looked into AudioBus yet. Still this doesn’t seem like an unusual request. I’d hope that this would already be possible inside Cubasis. If there are multiple inputs and outputs, allow the user to handpick which one(s) to use.

Hi Lars, I’m still not clear where to look for this. It’s not in settings > audio. Am I overlooking something?

Hi Lars, I’m still not clear where to look for this. It’s not in settings > audio. Am I overlooking something?

Hi Pinchy,

Please have a look at the Adding Audio tracks chapter of our Getting started with Cubasis tutorial clip, where routing is shown and explained in detail.

Hope that helps!


Thanks Lars, I appreciate you taking the time to respond. I do know of those options, but they only show inputs by number, they don’t show whether Cubasis properly identified external hardware. I guess if input 2 is not available, that is an indirect indication that the external unit wasn’t recognized.

Wouldn’t it make sense to at least show the name of the detected IO device in the Audio part of Settings? It’s like that in Cubasis 2, not sure why it was removed in Cubasis 3.