Cubasis 7 - Recording cuts out before I click Stop

Using this program for a while now and I must admit I dislike it, but have to use it because it cost too much money to replace at this stage. One problem that is particularly depressing is that sometimes when I’m recording, when I play back I find the recording has stopped a short way through my performance. I can’t work out why this happens - what hidden control is responsible? It seems completely random, which is very inhibiting for anyone recording good music - having to wonder if all the music is going to be there, or will it cut out for no reason? What do I have to do to ensure that the recording will continue until I press STOP?

Do you have your range set to record the full length of your piece or else have the continuous (recirculating) recording turned off?

Thanks jgrnfld, I’ll have a look at those settings next time I use it. I haven’t deliberately changed anything so I must be doing something accidentally.

No, it seems it’s nothing to do with me or any settings. It just randomly stops recording, quite frequently. And then when you try again, without changing anything, it’ll do the whole recording. But then on the next attempt, at any random time, it may stop recording. An unuseable program, unless you don’t mind turning into a nervous wreck.

OK, found another thread about this problem - looks like it’s a compatibility problem with Cubase & Windows 8. I’ll read through it and see what advice they offer.

I went from Windows 7 to Windows 10 and haven’t had that problem. Or any problem…

I had the same problem today with Cubase 7 Elements on Windows 10. Very strange. And it stoped recording at different length. Sometime under one minute and sometimes after about four minutes. So it seems there is no setting I did unintentionally. (I am not a Cubase master).

I asked Steinberg a couple of days ago but did not get an answer. I am still facing the problem. I do not know why. But I suppose it has to do with Win 10 which I switched to recently.

Here is an older discussion from 2013 about Win 8 and the problem mentioned.
http://www.steinberg.net/forums/viewtopic.php?f=196&t=34042&p=221641&hilit=cubase+stopped+recording#p221641

I deactivated Audio Guard in the Project setting. It worked thus far. No stops. But too early to be sure.

I am having this exact issue with elements 7 on win 7 - I don’t have an Audio Guard setting in my project setup, I have made the project length 99.99.99.99 and yet elements will randomly just stop recording. Once twice maybe and then it works for 90 min the next time same thing - it stops recording randomly and after a couple of start overs it will work for a long period, but the random stops are killing me. Was a solution ever found for this?