Cursor Position when opening editor Cubase 12

I have preferences set to “Double Click opens Editor in a window”.

When I open the editor, it shows the beginning of the event and and not my current Cursor position (like I was used to). If click the “F” AutoScroll key, it jumps to the current position.

Is there a setting I am missing?


No, there is no settings. It works as specified this way.

Not in previous versions. They were opening at the current project cursor position.

1 Like


Which version exactly do you refer to, please?

This post? Cubase 12.

Most recently using Cubase 11.


Sorry, I mean the previous Cubase version you mentioned. It was definitely working the same way (as Cubase 12) in Cubase 11, 10.5, 10, 9.5 and 9. I don’t have the previous versions installed at my system.