Custom noteheads printing

I have successfully implement a custom notehead, which appears fine on-screen. However, it does not print … have I omitted something?


It’ll only be possible for us to help diagnose the problem if you provide more information, preferably the Dorico project itself in which you’re having this problem. Please consult this sticky post for how to ask for help effectively here:

So - as ever - when I looked at the problem again it is not quite what I thought.
I have tried to make two new notehead sets, one with no notehead (!) to have stems-only for an aleatoric passage. The note head edit panel in each shows the notehead with a small red triangle in the upper LH corner of the edit frame. When I change one of these, both are altered. So in fact my ‘no notehead’ set removed my other notehead (why it didn’t print). I cannot seem to make a ‘new notehead’ without it being similarly linked to all the other new noteheads, despite them having different names. I cannot see in the manual how to delete notehead sets (since I now have a few). Any guidance on creating notehead sets would be helpful (I have read the manual, but can’t quite see where I am going wrong). Thanks!

You should be able to delete Notehead Sets by selecting them and then clicking on the bin.
I think they cannot be deleted though, if it’s in use in the project.

The important thing to know with Noteheads and their Sets is, they they are two distinct objects:

  • noteheads are the visible dots on the page
  • notehead sets are just a collection of noteheads

This means, that the same notehead can be part in multiple notehead sets - altering it in one set of course logically induces that it’s altered in the second set as well. In the end it’s the same object which is referred to in two different sets.

So you need to create a completely new notehead - this is achieved the easiest by duplicating the existing one, removing the old one from the set and then altering the duplicate in the editor.

Thanks! I removed the new noteheads from the score, and deleted the notehead sets.
However, on the second attempt, I still have a red triangle in a notehead I cannot delete and which appears in every ‘new notehead set’ I make. Changing one of these changes them all. I have put the notehead I want as a second head in one fo the sets, but am not sure how to get it to appear?
Screenshots attached. Thanks for your thoughts on this.

Can it be that you accidentally changed the default black notehead to an empty one? That would explain why it’s appearing in every new set, as usually the default black notehead is appearing in these cases.
The red triangle usually refers to some deviation from the original, but shouldn’t bother you too much in the case of noteheads.

You have to remove the first (empty) notehead from the notehead set via the arrow pointing outwards of the U-shape.
Then you can apply the set to the noteheads in your score.

Thanks for the help. I’m still not clear about the red triangle, which appears automatically whenever I add a new n-h set, and then cannot be deleted. But you have given me confidence that I can sort it out somehow.


Notehead Set creation is really quite confusing IMO until you get a good grasp of it. When you create a new Notehead Set, it is not populated with a new notehead that you can tweak to make a new set as one might assume, instead it is populated with an existing notehead. Any edits to that existing notehead will affect that notehead no matter what other sets they may be in.

After selecting New, do not edit the notehead that comes up. Instead select New Notehead at the bottom of the box.

This has now created a new independent notehead that is not linked to any other set. Next click the first notehead that your new set was originally populated with, and remove it with Remove Notehead from Set.

Now you should have an independent Notehead Set and any edits you make won’t affect other sets.


Ah! That’s what I needed to know. Thanks so much.


1 Like

I hope this is something that can be revised. I agree it’s very confusing at present.


Thanks all. I am getting somewhere. I have now reset the ‘sets’ to their factory settings, and have a new Noteset. However, I am unable to remove the ‘original’ - or indeed the new note from said Noteset. (see clip attached). Any thoughts on this?

Thanks again!

Did you use this notehead set already somewhere in the score? You are unable to move noteheads out of Nothead Sets, which are currently used in the score.


Sorry not to have cracked this yet: I have removed all the new Notehead Sets, and reset everything to the factory settings. At least doing that gave me confidence that I can see what is happening. I have now followed the instructions to 1) create a new Notehead Set (which arrives with a default notehead) 2) create a new notehead within the new set. But I still cannot delete the default notehead (see attached screenshot). Is this necessary? How else can I get the new, edited notehead to display?

I am sorry, I am not finding this to be true for me. Did you follow the exact steps as I?

Did you try them with a completely new project?

Hah! Well, I was just prompted to install Dorcio 4.2, which I have now done, and everything works just like you say. So problem solved. I don’t know if opening my Project in the update just cleaned up a glitch somewhere, or if the update was actually the solution: but either way, I have now done what I intended. Thanks so much for all the help and guidance, without which I would have been floored.