Cut not snapping to bars

Anyone else finding that when they cut on a bar with snap enabled Cubase isn’t cutting exactly on the bar?

The snap is following quantise and it pulls the cursor the bar but when it cuts it is minutely off.

Doesnt happen every time. I’ve not figured out under what conditions it’s happening.

Wish I were replying with an answer, but I do have the same issue…and I’m surprised there have been no responses to the couple of “cursor snap” inquiries. Not even one of those “you’re an idiot - all you have to do is click on the snapometer setting in the cursorscope tab of the quantifier menu…”

But I’ve tried all the options that seem relevant, to no avail.
Clicking on the vertical gridline at, say, bar 98 looks good - until you look at the transport or zoom in enough to see where it really is.

Maybe it’s listed in some “known bugs” list or something. I’d think it would be a higher priority given the lost productivity trying to align things once you hear something is off.

On the other hand, I’d also think that if it were really a bug there would be more than a few of us that experience it…so maybe I’m just imaginating…

Check the “Snap Type”. The button for snap type is just to the right of the snap On/Off button (it looks like a tic-tac-toe grid). You probably do not have it set to "Grid. Check the manual out for the definition of the other snap types.

Regards :sunglasses:

On the toolbar:

  • activate the Snap on/off button
  • in the Snap Type menu select Grid
  • in the Grid type menu select Bar

Thanks to you both. Still interesting behavior.
I did have the snap set to Grid, but the Grid type was on “Use Quantize”.
I set it to “Bar” and it snapped as expected.
The interesting part is that I then set the Grid type back to Use Quantize and it continued to work, snapping according to the quantize setting.
But bottom line is that the solution was once again hiding in plain sight. I just looked in the nooks and it was in a cranny.
But hey - that kind of thing keeps me humble… I appreciate your taking the time to help out~

Hi there,

Just a thought, have you got snap to zero crossing activated?

I remember that I had issues with snap accuracy and it was because I had this tool activated.

Hope it helps,

Jim B

Hi there,

Just a thought, have you got snap to zero crossing activated?

I remember that I had issues with snap accuracy and it was because I had this tool activated.

Hope it helps,

Jim B

Only happened on the very first track I worked on in C9 - not noticed it again.


Normally works on snap to quantise -

Rarely use zero crossing option.

Yes that’s as expected.
The rules are:
Setting the grid type to ‘Bar’ means you will snap to bars (always and regardless of what is set in the Quantize menu).
Setting the grid type to ‘Use quantize’ means that you will snap to whatever value is chosen in the Quantize menu.