Cycle Marker Batch Mixdown With TimeStamp Per Cycle Marker


Is there an easy workflow that I’m missing to use the render queue for multiple cycle markers while adding a timestamp to each rendered item?

I have 4 cycle markers, I want to create four files, each with timestamp information where each cycle marker starts.

It is a process to add each marker to the render queue manually, then set locators to marker 1, update the timestamp info, set locators to cycle 2, close and reopen the mixdown window so the timestamp updates to the new position, update marker 2, etc repeat for however many cycle markers I want to render.

If there’s a workflow or process to help with this, please let me know!


Timestamp is always added if you choose the right file format.

I don’t know why you are doing it manually.
It’s easy to configure what should happen…

Which Cubase?

Oh, please explain further! I’m on Pro 12.

Every time I add to render queue or render anything with timecode, I have to select the gear icon and check the “use timecode”.



With the queue, I have to do this for each item (cycle marker). Ideally I’d like to simply press a button and it renders the stereo out for all cycle markers with timecode baked in the wav file.

Make a preset?

This preset suggestion doesn’t answer any of my requests. It doesn’t even contain the timecode checkbox in the preset, let alone do what I want to do with cycle markers.

I’m sorry, but I thought it is obvious.

Make a preset for your file type settings.
And add the cycle markers to the export queue.
The wav file will contain timecode.
If you need to set the timecode different from the position in the current project, you need to set it in the dialog.
But how should the software know what timecode you will set?

I really don’t understand what the problem is.

So I rely on the Cubase function, Edit > Move > To origin. I use this a lot and it aligns rendered cues to the proper timecode in a “master” session. When I render a wav, this info is not baked in, and thus “To Origin” does not work. I have to go to “use this timecode” as specificied above when rendering in order to get this to work. The “Use This Timecode” does NOT seem to get saved in a preset, and thus I have to check this each time. If there is a way to utilize this “move to origin” function with a standard .wav please let me know what I’m doing wrong.