Cycle Marker Question

I’m trying to figure out how to get my 2 marker tracks to work together. I have one marker track that has the entire song’s locate points all mapped out. I have a second marker track with only the cycle marker points located on it.

My goal is simple, use Marker Track 01 to navigate the entire song, or switch to Marker Track 02 to run the cycle markers when rehearsing a section or tracking a solo without stopping.

The problem is that when I switch back to Marker Track 01 from the cycle marker track, my start and end locate points don’t work! :astonished:

Example: my song is 150 bars long. I’ve got a 2 bar click count in. So, my start measure is 003 and my end measure is 150. On the Cycle Marker Track, my start and end points are ST:081 - ED:098. When I switch from Marker Track 01 to MT 02, my locate points switch from 003 - 150 to 081 - 098. But when I switch back to MT 01, I only have 003 in both my start and end points!

How do I get it to go back to 003 - 150 WITHOUT having to manually reset it every time?

If you put them all on one track, do you get the functionality you want?

No. I tried that originally and it screwed up all of the locate points. It would only enter ONE locate point into both the start and end locators. So, I couldn’t find anything. That’s why I decided to TRY multiple markers. That way, if it screwed up, I could just delete the second marker and go back to the 1st without scrambling all my original locate points.

It’s still scrambling the locate points now. But, I’m guessing because I have the second window, it’s restricted to the start and end window. Before, it actually scrambled the marker window. I thought maybe if I could disable the second marker window until I needed it, that might serve as a workaround. But, there’s no disable function on marker tracks.

I really liked the idea of being able to have a cycle marker track IN ADDITION to the regular marker tracks. I could really use this function. But I can not get it to work as I understood it to function. So I keep having to just manually make cycle markers and then delete them when I’m done in order to keep my original points. It’s very annoying. Have you ever gotten it to work?

Use single markers for your locate points and cycle markers for your cycles.
You can assign a Key Command for each type of marker.
Both in one track should work fine.


That’s exactly what I’m doing. But they don’t work fine. The cycle markers screw up my single markers. Every time I set up a cycle marker, my start and end points for my single markers are LOST until I remove the cycle marker! That’s what happened on the single track and that’s why I tried a second marker track. The cycle marker on the second track is still doing the same thing to my single marker track but, at least it doesn’t scramble the order in the single marker track, like it did when I had them both combined.

I have one marker track with cycle markers only. If I want to play the whole Song from beginning, I have a macro for this, assign to a key command. Ok, it’s not what you a looking for …

So, I just tried what I thought you wanted to do and I realize now that I don’t quite understand what you want to accomplish and how you’re now trying to do it. Since both Fredo and I feel it should work using a single marker track, could you try that again and do a clear step-by-step reproduction of your process and clearly show where it goes wrong?

I just still have the feeling that it should be working…

MARKER TRACK 01: START: 003, 015, 028,… 102, 115, etc…END:150

I switch from MT-01 to MT-02. My loop cycles between 081 and 098. If I stop at measure 92 for some reason and then hit the start button, it jumps back to 081. This is good.

I switch from MT-02 to MT-01. My start AND end points now say 003! If I hit the end locate button, my start and end points now read 150! If I hit locate point 046, my start and end points now say 046. I have to manually go to the end point and load in the 150 in order to restore the original ST: 003 - Ed: 150.

Ok, I’m beginning to see part of the issue, but not why you’re not finding a solution (I need more coffee and less over-night work :frowning: )

So, there’s the preference “Cycle follows when locating to marker” which will quite logically make any selection correspond to the cycle a cycle marker covers, and then obviously not give you any selection if the marker has none, and single markers have none. So it sounds like that’s what you have going on.

When I tested this at first I had that function off, and when it’s off locating to a single marker won’t create a selection (over which you’d loop). So you can create a key command to toggle that function, or you can use “Recall Cycle Marker”, which will automatically set the selection/loop range.

So, it seems that having two tracks won’t solve your ‘issue’, but to me it seems to behave logically. So I’d just go back to setting it up using one track and figure out a workflow that works for you. Off the top of my head one thing that is confusing me is that you (seem to) expect a cycle/selection-range between 003 and 150 when switching to MT1. But that track only has single markers, not cycle markers, so logically that shouldn’t happen. But, if you wanted that to be selected, why would you not just create such a cycle marker instead (003-150) and put that on the same cycle marker track?

I don’t want cycle markers in the single locate point track. I want it to go back to NOT being in cycle mode.

Ok, but I’m clearly having a bad day or you’re not being clear. You said:

“I have to manually go to the end point and load in the 150 in order to restore the original ST: 003 - Ed: 150.”

What does “load in” mean?
What does “ST: 003 - Ed: 150” mean?

I thought you wanted a cycle over the entire song since you mentioned 003-150. If you DON’T want Nuendo to have a cycle selected, then why is having your “start AND end points” at the same location a problem?

So as I think I said; By turning on “Cycle follows when locating to marker” you get cycle marker selection in the ruler so you can loop when you select or recall your cycle markers, but NOT when you recall a regular marker. That works for a single track OR two tracks.

You may at this point want to either go through the exact terminology used by Nuendo (because I’m lost now), and/or post some screenshots to explain, along with what the resulting problem is from the unwanted behavior.

PS: I’m assuming you tried toggling the setting I mentioned earlier on and off…(?)

Okay, I’m guessing that you can’t do what I want and, yes “Cycle follows when locating to marker” was the culprit. I was hoping the preference would be track specific. I want it ON when in “cycle node”

(note transport settings ST: 081 ED: 098) and I need it OFF when in “song locate mode.”

(transport settings show ST: 003 ED: 149)

I programmed a toggle switch on the MC control to turn the preference on and off. Once it’s off and I switch back to “Song Mode”, I will have to manually go back to the transport window and type in 149 for the end point. It’s not perfect but it will suffice. Thanks for your help.

Ok, so I understand what you’re saying, but I really really don’t understand why it matters. Can you explain?

I mean, I understand that you want the cycle range set to 003-149, but then want to be able to select a marker between 003 and 149 without changing that. But why? Say you set that range and locate to bar 88, then what? Are you expecting to punch out at 149 or loop back or something? Because if you’re not actually using the 149/end point then why does it matter if it’s there or not?

What am I missing?

The only other way around it as far as I can see is to never use “Cycle follows” and instead use “Sync selection” and then you can set the cycle range manually via a key command. That might actually be easier since you’ll know that whenever you need to make a cycle you’ll first select the cycle marker and then press the key to create that cycle (on the transport). If you do it your way you’ll in a sense always have to be aware of the state of the toggle, which may be annoying. But again though, I’m not really understanding why you need the cycle range and the ability to navigate without it…