Dark Planet demo - no license found

I see no indication Dark Planet requires a demo license, but after install opening Dark Planet in Cubase 6.5.0 says:

“No valid license found for Halion Sonic SE Dark Planet presets
No valid license found for Dark Planet presets”

What is required here? I checked and Halion Sonic says it is version 1.6.1, which seems to be the latest. Is Cubase 6.5.1 or 6.5.3 required for this demo to run?

I see no way to load a demo license to one of my eLicenser keys a la the Cubase 6.5 demo. Rather frustrated having wasted time trying to sort this out with uninstalls, reinstalls, Media Bay scanning for the installed folders, reading the Readme and Steinberg pages on Dark Planet.

Any ideas?

Dear csd,

you should have received an activation code for the demo license per e-mail, together with the download link for Dark Planet. Haven’t you received the e-mail?


The “Try now” link on the Dark Planet product page just sends us to a download link for the Mac or Win versions of Dark Planet. There is no email address request there, or mention of needing or receiving an activation code (whether logged into my account or not).

When I log into my account, the trial versions link only lists Cubase, Wavelab, Nuendo, Sequel and the Neve Portico products - no mention of the VST Instrument collection. The Activation section of my account lists the VST Instrument collection, which leads to Dark Planet (and the others), but that is for a reinstall and reactivation (requires the old activation code).

Did I miss a hidden link to get an activation code somewhere?

i down loaded the rial and the vst3 is working and has not asked for an activation.???
so will it stop working in 30 days?

That’s strange. Do you have the full version of Halion by chance? Just Halion Sonic SE that came with Cubase here.

I tried it on another system under Reaper (doesn’t have Cubase, but there is an eLicenser key connected and the control center installed), and when Reaper scans the Dark Planet dll, it says no valid license found, check to see if there is an eLicenser connected. Of course there is no activated license key on the USB key there, so that seems to make sense.

Not sure how you have it working on your system.

hi i’m using hs se.i have triebwerk already installed from a while ago .and i checked there’s no licence on my dongle .i am also on mac osx.
maybe its a freebie lol

Maybe it’s free for Mac users but not for us Win users, lol.

Its not free steinberg had placed a sel dongle on my hard drive .did not see that there.

I gave up and uninstalled it. Work to do and there are other options. I was curious to see if DP might offer some additions to what I have.

Sorry Steinberg - this is a perfect example of when copy protection prevents sales.

Dear csd,

I’m sorry, I gave the wrong info. The demo license for Dark Planet actually gets activated during the installation, but you need a Soft-eLicenser for that. Can you please check on your eLicenser Control Center if you have a Soft-eLicenser generated? If not, please check this article: https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/program-installation-does-not-create-a-soft-elicenser.html

Also you need the latest version of the eLC: http://www.elicenser.net/en/latest_downloads.html

After that, please run the Dark Planet installation (As Administrator) again.


The first link is just the general license info page. There is nothing about a missing elicenser install. How much time does Steinberg expect me to volunteer to solve your license problem? I’m only here because I like to solve problems but this has already cost me more in my hourly fees than the cost of the product.

Hi csd,

I’m sorry but i’ve tried it on my system many times and it works. Have you uninstalled it and run it again ‘As Administrator’? It should work!


I figured out the eLicenser Dark Planet installed was either not up to date, or not installing over my version, for whatever reason.

The SEL was showing up in the eLicenser control center, but the application description was blank - a blank soft-license. I downloaded the latest LCC, installed it, and reinstalled Dark Planet and DP now shows up in that SEL slot. And on this reinstall of DP, DP did not try to install the elicenser as it now saw a later/current version. Not sure why it had issues with it’s own installed version.

Yes. Something is strange here. I installed the Dark Planet Trial. I Have the current e-LCC software (24 May 2013 version). The license shows up as a soft license SeL in eLCC control center. I can load Dark Planet as an instrument (it’s standalone version) and play the presets. Everything seems fine BUT it is ticking down my “All Applications” (the 24 hour blanket) license! I also tried to load the Dark Planet presets in HSSE to see what would happen. The presets are there in HSSE but when I select one to load it, Cubase totally locks up.
I sent in a support ticket.

Just thought I would follow up in case this may help someone. I never did get support to address the presets for Dark Planet not loading in HSSE (causing the lock up of Cubase altogether). I gave up on it since I can still demo the instrument in it’s standalone VST mode. As far as it using the 24 hour All Applications license on the dongle EVEN though there is a Soft e-Licenser on the computer for Dark Planet Trial, they told me that it is an INTENDED behavior for the 24 hour All Applications license to be used (and counted down).
I guess, since the purpose of the 24 hour license is to allow use of the product until activation occurs, I have no legitimate gripe BUT it would be nice to be able to save that All Applications license for emergencies.
EDIT: I moved the “All Applications” license to another dongle and now, the Dark Planet Trial works perfectly as a standalone AND inside of HSSE. Definitely something strange with the way it looks at the licenses.

I have the same problem with the presets from the VST Instrument Sets causing Cubase to totally lock-up when clicked on inside of Halion Sonic SE.

The demos have since expired for triebwerk/dark planet/hypnotic dance but the presets remain in HSSE and if I accidentally click on one while browsing sounds it’ll cause Cubase to freeze. It’s very frustrating since I’ll have to force-quit Cubase and lose any unsaved data. How can I just wipe those presets away so they don’t obstruct my workflow?

For trial installations of Dark Planet, Hypnotic Dance etc. no license email will be sent out. Therefore, you MUST check mark the ‘Start the license activation process after the installation’ on the last step of the installation process, during the installation. Otherwise, it will not work and you must re-install it.

Just ignore the ‘License Registration’ window after that.