DAW Control Issues

Hi All.
I have a Behringer X32 into Cabse on my PC. I cant seem to get the faders to link to Cubase and work. I got X32 Edit and that connects to the X32 and that allows you to rename tracks and change levels but I’d prefer to use Cubase for all of this.

I’ve been at this for a few days and any help would be very much appreciated.

Hi and welcome,

Behringer X32 is using Mackie Control protocol.

Open Studio > Studio Setup. Click the + button to add a new device. Choose Mackie Control from the list. Mackie Control device will be added to the list. Set the Behringer MIDI Ports as an Input and Output. As far as I can see, X32 has 16 faders. So add another Mackie Control 2 device and set the 2nd MIDI Port to be able to control 16 Cubase faders.

Be aware, Mackie Control 2 is the 1st bank (channels 1-8) and Mackie Control is the 2nd bank (channels 9-15). Set the MIDI Ports accordingly.

Don’t forget to remove the Mackie Control MIDI Ports from the ‘In All MIDI Inputs’ list in the Studio > Studio Setup > MIDI Ports, please. Otherwise X32 would send the MIDI data not as the DAW controller data only, but it would send the data to the MIDI/Instrument tracks too.

1 Like

HI Martin.
Thank you for getting back to me with some great advice. I did what you said and I am getting connectivity between the x32 and Cubase but… Fader bank 1 is not connecting or controlling anything and when I use the bank 2 faders on the x32 it changes the pan in Cubase.

I presume this has something to do with the ports/functions not being set up properly. Is the done in Studio/Studiosetup/Mackiecontrol- User commands? Or is this only for F key functions?

Thanks again for your help Martin.


I don’t think, this has something to do with the ports.

Please, first of all, make sure, X32 is set to the Mackie mode.

At Mackie Control, the faders send PitchBend data (channels 1 to 9), the V-Pots (encoders) are sending MIDI CCs (increment/decrement) value. There is a specific button, where you can Flip the faders and the V-Pots functionality. This button sends MIDI Note 50 (D3). Please, make sure you haven’t press a button on your X32, which would send this MIDI Note. Once you restart the device, the Flip should be reset, so the faders should control Volume.

Please, could you attach a screenshots of the settings in Cubase?

HI Martin,
It must be because I’m a new member but the forum isn’t allowing me to add any photo’s or links to web photo’s. I tried PM’ing you but it would not allow me to add the photo’s/screen grabs either. I only joined like 7 days ago, I don’t know, is it worth contacting admin to see if it can be lifted temporarily. Or would you have another way I can send these to you?

Thanks again


You are allowed to upload a screenshots, now.

HI Martin,
Brilliant. Thanks so much again. I have them attached now.

Thanks for changing my admin rights


As far as I can see, there is only 1 MIDI Port from X32. So there can be only 1 Mackie Control Device, what means you can control 8 channels only. You would need 2 different MIDI Ports to be able to control add 2 Mackie Devices properly and to be control 16 tracks.

Maybe, have a look to the X32 manual, what does it say about the Mackie Protocol.

Now when I have a look to the device again, I would expect, the only last 9 faders have been used for the Mackie. Sou you can control only 8 channels at once and then you have to bank to the other group of 8 channels. In this case, 1 Mackie Control Device is enough.