DAW controller and keyboard issues with controlling mixer


I have a ICON platform NANO and a M-AUDIO Oxygen Pro49 and suddenly i experience some issues with them.

Today i can’t control the channelfaders and mute/solo ect in the mixer anymore, only the master fader. This is on both the keyboard and the DAW controller.
Very strange. In my other DAW they work perfect.
So it must be something in Cubase. Checked all settings and nothing is changed.
I and i have often startup issues when i start Cubase, it freezes on the mackie controls…and i have to force shutdown Cubase in taskmanager.

I have Cubase 10.5 and i installed it a week ago on a new workstation. Maybe somebody experienced the same and has a solution or where to look…i am out of options now.

Hi and welcome,

Do you use Mackie Control protocol for these devices? Could you attach a screenshot of the Studio > Studio Setup > Remote Devices > Mackie Control, please? Is the Input.- and Output port set up properly?

Hey Martin. Thanks!
I found a bit the issue i think. Cubase puts the M-AUDIO keyboard as first controller and the ICON NANO second. As i add 8 tracks, all 8 i can control on the M-AUDIO with the 8 faders. When i add a 9th track, then i can control that 9th track and tracks after that with the ICON. Now i am looking on how to set the ICON as first controller. Not seeing a option for that in there.
This is the screenshot btw


OK, I got you.

If you want to use iCon as the 1st controller, to use the faders 1-8, you have to swap the inputs of the Mackie Control and Mackie Control 2. Then the iCon will work for the channel 1-8 and Oxygen will work for the channels 9-15.

In remote devices my Icon is ‘mackie control’ and the M-AUDIO is ‘mackie control 2’.
So they are in order. Or you mean to swap something else? Don’t see where i can swap more


I mean to swap these 2 Mackie Devices (to swapping the Inputs and Outputs).

Set Mackie Control as M-Audio and Mackie Control 2 as iCon. Cubase is reading the devices from bottom. So the best bottom device is always controlling the 1st bank (Channels 1-8).

Awesome, that did the trick. Never knew Cubase reads it from the bottom. Thanks alot!

So to be clear, i can just operate the first 8 faders with my Icon controller. It has a <<8 and 8>> button also to skip to the next 8 faders.
Now indeed my M-Audio keyboard faders take over from 9-15.