DCOM connection to program 'Synsopos.exe' failed.

Facing the same problem here. Still no solution found?

Edit : a solution would be to turn off the DEP system, but I don’t know if it’s really safe
https://www.online-tech-tips.com/windows-xp/disable-turn-off-dep-windows/
https://answers.microsoft.com/en-us/windows/forum/windows_8-performance/how-to-turn-off-dep-in-w8-x64/9d498623-8ebf-45d1-8d96-9fd9b0ca51d0?auth=1

Please help ! :neutral_face:
Cubase is closed with any error message

After reopen pop up this :

Application 'Cubase / Cubase Artist' has caused the following error: 
DCOM connection to program 'Synsopos.exe' failed.
     Error:The remote procedure call failed.
Options: 
 - Click <Ok> to abort.

When i tried to change DEP for SYNSOPOS.exe but :

Data Execution Prevention This program must run with DEP enabled. You cannot turn off DEP for this program

I Use :Windows 10 with last update , cubase 9 pro
Thank you

on win 7 64 ultimate same problem for me with upgrade from cubase 9, so i have
first uninstalled cubase 9.5 and turned totally off dep system as swendenn links says,
rebooted
reinstalled cubase 9.5, just the msi executable, and updated to 9.5.41.
no more problems.

This is outrageous!
I bought cubase 9,5 a month ago. Updated to cubase 10 few days ago. Today it crashes 3 times on simple 2 tracks mixdown with this mesage. “DCOM conection to program Synsopos exe faild”. Runing on windows 10. This should not happend with legal bought software. I am very dissapointed in steinberg to do this to it’s customers. Is there any hepl from steinberg? Can anybody help?

Hey Xantaresx thank you man! Your solution is working and you help here a big deal. Great work from you! Thx

I finally found a fix for this. I basically uninstalled the eLicenser from Apps and Features, then clean uninstalled the eLicenser from Program Files, Program Files (x86), Program Data, Users/Yourname/appdata, Windows/prefect, /system32, SysWOW64. Then went into the RegEdit and removed everything associated with eLicenser and Synsopos.exe., Did a system restart, re-installed the eLicenser Control Center software, LEFT THE USB OUT during the installation process, then inserted the USB, wait for Windows to download the driver, start up the program and it works! Please share this information on as this was a nightmare to deal with lol

I had this issue and updated my Elicenser today and boom problem solved. I had the same issue where Windows said it could not grant an exception for the file.

eLicenser Control Center 6.11.6.1249

Good day. I have a question on the seventh item, it gives an error when trying to add the SYNSOPOS.exe file to the list of exceptions:

This program should work with Data Execution Prevention (DEP) enabled. You cannot disable DEP for this program.

What am I doing wrong? Help me please.

My windows says this program can not be executed without DEP, what do I do?

Try run Cubase as administrator

Hi :slight_smile: In Windows 10, it is not possible to deactivate DEP for “Synsopos.exe”. However, you can deactivate DEP (Data Execution Program). Here`s how to deactivate DEP:

  1. Run command prompt as administrator.
  2. Run this command: BCDEDIT /SET {CURRENT} NX ALWAYSOFF
  3. Restart your computer (you have to restart).
  4. Check that DEP is deactivated: Control Panel -> System settings -> Advanced system settings -> Performance settings -> Data execution prevention tab.

If you want to activate DEP, you follow the steps above but instead use the command BCDEDIT /SET {CURRENT} NX ALWAYSON.

THANK YOU! You saved me from mental meltdown :smiley:

So… 8 years later and people still are getting this error… and people are sill needing to hack their way around… what is this? This is a big blunt middle finger to all the user base.

I created an account just to say this: I was getting the same error after a fresh install of the eLicenser, and I solved in with a different way… leaving this here for anyone whom the above solutions haven’t worked:

In my case, the problem arose because I installed the eLicenser while having my Steinberg USB interface (UR44) active in the computer (i.e. connected). It took me a bit of tinkering to figure out this was the issue. I stopped all audio/Steinberg programs, uninstalled the licenser, make sure all audio-related apps were set to NOT start at startup. Restarted the machine. Made sure all steinberg stuff was not connected, reinstalled licenser thingy, and it worked. Something in the installation had corrupted because the interface was connected while installed.

You gotta love Windows.

I had this same problem after a Windows update around 8/15/2019.

I unplugged my usb, uninstalled e-licenser from add/remove programs, restarted, DL’d and reinstalled e-licenser, ran the maintenance, plugged in usb, registered all through e-licenser, closed e-licenser, launched Cubase 10 Pro to find full functionality and no error.

Man, Steinberg sucks.

haha.

Just for anyone else with a similar problem, the quoted text actually helped me.
In my forum post - https://www.steinberg.net/forums/viewtopic.php?f=286&t=167363&p=894578 - I wrote a bit more, but basically deleting everything elicenser related from registry and from hard disk fixes the issue.

,/,

Solution that worked for me (win 10 64bit):

Uninstall elicenser and restart computer. Go to program files x86, locate eLicenser folder and delete it. Use Ccleaner software, go to Registry tab and scan for issues, let it fix/delete them.

NOTE: I didnt use USB stick for this, I got my cubase download access code on paper, registered it on their site, downloaded and installed cubase, checked back on my website profile and saw “Activation status:Not yet activated” then I used https://www.steinberg.net/en/company/technologies/elicenser.html to download eLicenser and then put the activation code(which I got on the page where I submitted the download access code) in the eLicenser software to complete license registration.

Hope this helps someone.

This doesnt works here: It appears this:

this program must be executed with data execution protection (DEP) enabled. You cannot undo (DEP) in this program

This worked for me!!! All Cubase executables need to run as administrator!!! Many thanks!!!

What is going on with this issue? I have it too and have not been able to fix it.
I have not been able to use Cubase for 6 months now and started using Mixbus.
Why does Steinberg sell software that you can’t use? Why don’t they fix this?

Did they fix this in the new release Cubase 11?