DDP Player issue

When I open a certain DDP file in the player for the last check it has a 4s pause inserted before Track #1
When I re-open the ddp as montague none of that appears.
No pause is selected or added in the original montague either.
I didn´t happen on any prior DDP.

Anything I could have selected by mistake?


If it only happens with one particular DDP, is the first track start marker not at 0:00 in the master montage, and you have montage Audio In Pause selected? That would create a DDP with a pre-pause in the DDP Player, but not necessarily in DDP import to montage, depending on whether you select Standard or Audio in Pause for the DDP import.

Maybe if you took screenshots of the DDP Player and the beginning of the master Montage it would help.

Screenshots. Hope it gives a clue…

Yeah, 2 of the seconds come from the fact that your first CD Track start marker is 2 seconds into the montage, and you must have Audio In Pause enabled for that montage. The DDP Player is probably adding 2 more seconds to the displayed time because of the standard 2 second pregap for track 1 that you normally don’t see or hear. If you play from the start in the DDP Player you probably hear 2 seconds of silence, not 4.

If you import the DDP back into Wavelab and select “Audio In Pause” instead of “Standard” in the import dialog, it should show you what’s going on.

If you always start at 2 seconds in the montage and you don’t get this effect in the DDP Player, it’s most likely because Audio In Pause is not enabled in your other montages.

You can either move the Track marker and audio to the left so the marker starts at 0:00 (what I always do), or turn off Audio In Pause for the montage. I always leave it on because I think it’s safer, like if you want to use Start and End markers but you want to leave tape hiss between tracks.

Ok. I figured it out. I had “audio in pauses selected” and an extra 2s pause added before the first track on the CD page. :smiley:
That added up to 4…

Actually those aren’t additive. They’re just showing you the same thing, on the CD Tab and in the Montage. The 4 seconds is what’s being displayed (and played!) in the DDP Player, which is adding in the normally hidden standard redbook 2 second pregap that you normally never see or hear. Except on the PQ sheet. Preview the CD PQ sheet on the CD tab. With default setting it’ll show that standard hidden 2 second in the Start (CD) column in any standard CD montage.

More important than any of this I think is to burn a CD from your problematic montage with Audio In Pause enabled as you had it, before deciding what to do about any of this. You should notice that the burned CD won’t have a 2 second OR a 4 second silence at the beginning. Because they’re hidden. The CD will play from Index 1, which is the position of your CD Track Start Marker in the Montage at start of music. That’s one of the things that’s deceiving about the DDP Player in it’s current state (at least until the upcoming update). In cases like this (interpreting how the Index 0’s and 1’s should be played) the Player is not playing how a CD will play in a CD Player, like it should.

I would burn a CD or demo the Hofa to see what the differences are at this point. The Hofa will audition your problematic DDP like a CD will play in a CD Player, from start of music when you click the play button. It will show the 4 second pregap, and you can go back and play the hidden pregap, but when you initially load the DDP and hit the play button it will play from start of music, like it should. Like a CD will.

When you load that DDP in the current Steinberg Player and hit play, it will play the 4 seconds silence, which is really not how it should be.

Basically your problematic montage is creating a 2 second “hidden track” before track 1. It’s how pre Track 1 hidden tracks are made. On a CD Player you would have to rewind to play that hidden track.

Edit: or you can just turn off Audio in Pause for the montage if you don’t need Audio in Pause for any of the other tracks, and it will act like a normal CD montage, with no pre track 1 hidden track. Or move everything back, to have the CD Track start marker at 0:00 in the montage.

Sorry to drag this out, but I think it’s probably a really bad idea to leave an unintended Track 1 “hidden track” even if it’s just silence, because for one thing, it puts the CD outside the Red Book spec afaik. Plus it wasn’t intended anyway. But I think it’s a good thing the DDP Player showed you one was there.

There are a couple of further issues:

If the user added pregap (“hidden track”) is less than 1 second, the Steinberg DDP player doesn’t display the Pregap at all (the “Forward” in the Steinberg Player). The Hofa player does. If the user added pregap is more than 1 second, both players display the Pregap or Forward correctly. The attached screenshot has a 60 frame “hidden track” and shows the difference in the players, with the Steinberg player missing the “Forward” section before Track 1.

In “normal” DDPs, neither the Hofa nor the Steinberg players display this “hidden track” Pregap or Forward at the top, so it’s only when “hidden track” space is added before the first CD Track Start Marker in the montage (intentionally or unintentionally), and Audio In Pause is enabled for the montage.

Also, of three players: Steinberg, Hofa, and iTunes, only iTunes is rounding the song durations correctly (1-37 frames down, 38-74 frames up). Hofa rounds down only, truncating. Steinberg rounds inconsistently - sometimes down when it should be up, and sometimes up when it should be down. Like Tracks 4, 5, and 8 in the attached screenshot.

I bought the Hofa player… :wink: