Deactivate audio?

Is there a way to completely deactivate Audio in Dorico?

You could do one of the following:

  • Turn your computer’s volume to zero :wink:
  • Mute all instruments in the mixer
  • Select the playback template “Silence” (Play -> Playback Template… -> Silence)

@ derhannes
Thanks for your suggestion but not hearing any sound is not what I am aiming at :wink:

I am trying to optimize the stabilty and the speed responsivness of Dorico working with a project with mutliple flow.
For some reasons which are unclear until now (I already asked Daniel and he is looking at this) I get quite often some kind of crashes and it seems it has often to do with the VST engine.
Also after some crashes and restarting Dorico I get a window telling me “Audio … dies” and I have to stop Dorico through the task manager and restart again.
As at the moment it is not necessary for me to have audio for all the format and layout work I wonder if there is a way to completely deactivate the audio engine until I need it later to prevent any unnecessary crashes.
I thought about deactivating the Audio Device in Audio Device Setup but there is no option for “No Device” or something like that.
The template silence is also choosed and I have no VSTi selected in my project but I am not sure that it completely deactivate Audio.
Therefore my question.

My guess is that the crashes you’re experiencing are not related to the audio engine, but until we have some crash logs to examine it will be hard to say. The fact that you get a message telling you that the audio engine has died when you restart Dorico is because the audio engine was still running when Dorico itself crashed; Dorico attempts to reconnect to the already running engine when it starts, but doesn’t always succeed.

@Daniel
Yesterday I have sent you several.dmp files, did you received them?

Independently of my crashes issue could you tell if it is possible to completely disable the audio engine when it is not needed?

No, it’s not possible to disable the audio engine via any options provided in the software. If you remove the actual executable then Dorico will run without it, but I would caution against that kind of interfering with your installation.

Daniel forwarded me the crash dump and I had a look.

There are 4 crash dump files of the VSTAudioEngine. Each time it fails in exactly the same way. The main thread starts and almost immediately aborts again, because it fails to send some ipc command via winsocket. This is all happening on very low, Microsoft runtime level code, so there is not any Steinberg code executed yet at that stage. Therefore there is nothing that I can do or further debug, because it is all too low level system.

On the other hand, there are also 2 other crash dump files, namely from auxhost.exe. This process is from JBridge (for running 32bit VSTs on 64bit hosts). For what plug-ins do you need JBridge? Is it possible that JBridge is interfering here and brings the VSTAudioEngine down? What if you disable it?

Thanks Ulf for chiming in.

Would it help if I once can exactly reproduce what happens?
As I understand these are not really “crashes” but Dorico seems to stop working and the screen becomes kind of milky/transparent.
But I suspect that I sometimes possibly quit Dorico too early (through the Windows 10 Task Manager) because Dorico seems to freeze and all of a sudden it works again if I wait long enough!
Dorico needs often quite a long time for certain tasks and unfortunately the program does not always give a clear indication on wether it is ready or not!

These Freeze/Crashes happen regularly with:
Add new instruments in a Percussion Kit
Remove Players in Setup mode
Save a project
And very often when I inadvertantly click to achieve something else when Dorico is still not ready acomplishing a task.

I have jbridged:
Native Instrument “B4 II”
Refx “Vanguard”
Speedsoft “VSampler 3”
Tone Projects “Sonitex STX-1260”
Ultrafunk “FX suite”
URS (7 Plugins from them)
Voxengo “Pristine Space”
… and a few others.
I need these plugins to be able to open a lot of older projects in Cubase.
Of course since years I avoid to use any of them for newer music.
I work with Cubase extensively and I have almost never any crashes with it, so I keep JBridge as it is really usefull for me.
And of course I have not declared any of these jbridged plugins for Dorico.

I also don’t use Dorico’s Audio extensively, and if I do it it is only for correction/monitor purposes to hear if there is any notation mistake.
For this I try to use only a few instruments.

But I can test and disable JBridge for a while and see if it behaves better.

Yes, it would definitely help, if one could exactly reproduce what happens.
Dorico is not crashing, but the audio engine does. So if Dorico starts up, then it will also launch the audio engine process, but if that one immediately dies, then Dorico will wait and after a few seconds show the “audio process died” message.
Also, it would be good, if you could examine the state of Dorico and the audio engine in the task manager when the freezing happens. If one of them is shown as “not responding”, you can select the process in the list, then right click on it and from the pop up menu choose “Create dump file”.

In regards to JBridge, I don’t know, but I guess it is running in the background all the time. And though you are not using jbridged plugs in Dorico, it might still be that they interact somehow and get in the way of each other. So yeah, I would suggest to disable JBridge while using Dorico and see if that makes a difference.

@ Ulf
OK, thanks for your instructions.
I will collect all these informations when possible.

Is it still the case that it is not possible to disable the audio engine in Dorico?

I am engraving a large score for which I do not need to use the playback function in Dorico at all. As the score has become larger, the Beach Ball of Death has been showing up more and more frequently… It is now almost impossible to enter even a few notes in Dorico, or even scroll on the page, without Dorico pausing to think for about 30 seconds.

About my system:
iMac, OSX Catalina, 8GB, 1600 MHz, 2,7 GHz Intel Core i5

When I open Activity Monitor while running Dorico, I see that “VST Audio Engine” is by far the most memory-heavy process. Given that I simply do not use the VST Audio Engine at all, ever, I would love to be able to simply deactivate this, in the hope that it would speed up Dorico.

As in the earlier conversation, you’re assuming that the audio engine is the cause of your problem. But it’s not certain that just having the VST using some memory is the cause of beachballs and system slowness.

I’m guessing this is a 2013 iMac? Are you using Condensing? That’s CPU-intensive. Presumably you’ve got a mechanical hard drive in there, either one its own, or as part of a Fusion drive, which is also going to be a limiting factor.

I would worry about the reliability of a 7-year-old hard drive, and start thinking about alternatives. You can upgrade the RAM to 16 GB, and I would certainly recommend doing that, for starters.

Have a look at what else is going on in Activity Monitor: Disk usage, CPU usage. But you need to provide the team with a Diagnostic Report (from the Help menu).

Thanks for the reply, benwiggy.

This is indeed a 2013 iMac. I’m not using Condensing. My hard drives are all SSD.

You are correct that a RAM upgrade is in order. However, I would like to complete this current project before any hardware upgrades. With an eye to this fact, I reformatted my drives and ran a clean install of my whole system in March of this year. All other programs have been running smoothly since that clean install; I can still perform processor-heavy audio editing in Logic with no crashes. There is nothing else showing in the Activity Monitor that could be causing these kinds of constant delays.

As a stop-gap, I have unregistered unnecessary audio engines in the Steinberg Library Manager. I have also broken my large Dorico file into multiple files, one for each Flow in this multi-movement work. This might (?) get me over the finish line on this project, but the program is still painfully slow.
I’ll run a diagnostic report.

In the meantime, I would love to hear other suggestions about how to reduce Dorico’s CPU and memory usage.

It’s difficult to know without seeing the project. A few things that do seem to make a difference for some users:

  1. (With Dorico closed) Open your Applications folder, right-click Dorico (whichever version you’re using), click “Show Package Contents”. Click through Contents > Components, grab videoengine.bundle and drag it somewhere else (the Desktop, or even the Trash!). Then try running Dorico again.
  2. Within Dorico, go to Playback Options (Cmd-Shift-P) > Repeats and untick “Play Repeats”. Apply and close.
  3. Misbehaving MIDI controllers have been known to flood Dorico with data. It’s worth disconnecting MIDI devices for a few minutes, just to rule out that possibility.

Also the IAC MIDI bus, which can ‘feedback’.

Thanks for the ideas pianoleo!

While performing step 1 as mentioned above, I noticed that I had left Dorico 3 installed when I upgraded to 3.5 a few months ago. I had left 3 on for safety, while I verified that 3.5 was stable, and forgot about it… I wonder if 3.5 will run more quickly now that I’ve uninstalled 3.

I’ve also performed your suggestion 2 above, and checked my MIDI controllers. Having completed these steps, and broken my single giant file into its component flows, Dorico seems to be running fast enough now that I can return to note entry and layout tasks, as long as I am cautious about not entering any key commands too quickly. Fingers crossed that this will remain stable enough that I can reach my deadline.

In the longer term, I am still interested in finding a way to deactivate the playback function. As I simply don’t use it, it seems a waste of CPU usage to have a VST Audio Engine running in the background every time I use Dorico. I love the Write and Engrave functions, but don’t need Playback.

If I set the playback template to Silence, the audio engine uses less than 1% CPU even if I hit play, even on a very large project (more than 100 staves, several flows each with 1000 bars of music).