Default to record only 1 track at a time

I do large recording projects, where I am overdubbing many parts. Sometimes I accidentally leave a track that’s offscreen record enabled, and don’t realize it until much later, leaving a mess to clean up. I believe that in Protools I was able to set t to where if I record enabled a track, the other tracks would disarm their record enable, UNLESS I held down the shift key. By holding shift, I could arm multiple tracks, but if I didn’t hold down shift, only one track at a time would be set to record. Does this feature exist in Cubase? It would be extremely helpful to me. Thanks a lot to anyone checking out this thread!

+1 like to know about this 2!

Hi,
You could make a macro for this and assign it to a Keycommand.

Call the macro “Record Only Selected”

Add the commands

  • Mixer - Deactivate Record Enable for All Audio Tracks
  • Edit - Record Enable

Now search for “Record Only Selected” and assign it to a Key Command.

Please also see the attached sreenshot to see the macro.
RecordEnableOnlySelected.PNG
Maybe this works for you.

If you want to make it work with MIDI and ChorTrack as well and not only on Audio you must create your own command by adding a small Logical Preset to the Keycommands and from there to the Macro.

Go to the Project logical Editor and make it look as shown in the attached Logical Editor Screenshot and call it “Deactivate Record Enable on Audio, Midi and ChordTracks”.
Deactivate Record Enable on Audio, Midi and ChordTracks.PNG
To make it appear in the Keycommands list you must click on the small + icon in the upper left of the Logical Editor to save it as a preset. Now the preset will be in your Keycommands list.

Now make a Macro that looks like this:

Add the commands

  • “Deactivate Record Enable on Audio, Midi and ChordTracks”.
  • Edit - Record Enable

Dont forget to give your macro a describing name and assign it to a Keycommand.

These macros will disable all record enables in the project and only activate record enable for the track or tracks you have selected.

Be aware that the preference
Editing --> Track Selection Follows Event Selection (should be off by default)
and
ProjectMixConsol --> Enable Record on Selected Midi Track (is on by default)
ProjectMixConsol --> Enable Record on Selected Audio Track (is on by default)

also play a role for this slip to occure.

The macro solution is worth a try and maybe fits for you.

Greetings,
JHP

I don’t think so, could be very helpful to have.
The only way I can think of as a help is to use the “Project Logical Editor”. Something like :

Media type equal Audio
TrackOperation Record Disable

That would disable the Rec Arm on any audio track, then in combination with a macro it could turn the Rec Arm back on for the selected track only.
Sorry that is just a few thoughts on a workaround, not very helpful i’m afraid.

Edit Ahh someone beat me to it :slight_smile: