Delay compensation not working

Hi,

I am new to Cubase trying to figure everything out. I am putting a project together and I have a bunch of tracks routed from Superior Drummer and using a bunch of plugins on those tracks (mostly EQs, saturation and compression) and for some reason Cubase is not compensating for the different latency values of the different channels and so everything plays back out of time. I have been looking and I can’t seem to find any settings pertaining to this. What am I missing?

Do you have delay compensation turned on? Or to put it in Cubase terms, do you have constrain delay compensation turned off? It’s also possible you’ve got a plugin incorrectly reporting its latency value.

I assumed it would be on by default like it is in every other DAW I have ever used. Where is this setting?

Also the plugins are plugins I have used before in other DAWs and they have always been fine.

EDIT: Apparently “constrain delay compensation” it was already off, because turning it on turned some of my VSTs off. So that is not the issue.

Ok I found the culprit, it was the linear phase setting on Fabfilter ProQ. Is there a way to have ProQ on linear phase and still get proper delay compensation?

You’ll have to ask fabfilter about that.

Actually just checked in pro tools as well and its the same, in Pro Tools however the manual states that the maximum latency compensation is 16383 samples, and the delay introduced by linear phase processing of ProQ is 17408 samples which means Pro Tools can’t compensate for it. I suspect this is what is happening in Cubase as well. I can confirm that Reaper’s ceiling is either much higher or potentially unlimited and that this issue is not present there.

So given all that, is there a way to increase the maximum latency amount that can be compensated for in Cubase?

Also its not just with ProQ, I have just tried another high latency plugin from Waves and its behaving in the same way.