Delay when recording my voice

Hi all! :slight_smile:
I have a very simple project with two tracks: a guitar and an audio track. I’m recording my voice in the second track, using notebook’s integrated microphone, while I’m listening to guitar track with my bluetooth headphones. The problem is I always get a little delay when recording my voice, so the audio track is a bit late with respect to the guitar.
What can I do? I’ve tried what I’ve read in other forum topics to reduce delay, so I disabled the WiFi adapter in Windows’s Devices Manager, and I disabled Norton Antivirus. But I still have the same delay.
Should I just shift the voice track backwards to compensate the delay? How can I do it?
Thank you in advance for your help! :slight_smile:

Bluetooth. Unless you have the latest greatest Bluetooth receiver and transmitter, you’re getting a delay. I have a pair of wireless headphones that use RF and not Bluetooth, for exactly this reason.

1 Like

As said by @shagazulu , Bluetooth headphones most probably won’t report their latency to the host, especially since you are using an aggregate driver.
The headphones need to have their own dedicated ASIO driver for this to work, and they are not Bluetooth but 2.4 or 5 GHz.

You can know the exact delay by enabling the metronome and recording short clicks, for example find a small plastic or metallic object and click it on the table as accurately as possible with the metronome.
After that, set the ruler to seconds, zoom in, and look how much time there is between grid beats and the recorded audio. Note it somewhere, and you can now nudge your tracks by this value.
You can create a PLE preset for this.

1 Like

Hi @shagazulu and @Louis_R ,
thank you very much for your answers!
I’m currently using bluetooth headphones just for the output, but for input I have selected in Cubase to use the notebook’s built-in microphones. Do the bluetooth headphones influence on the delay also if I’m using notebook’s built-in mic?
I’ll try to check the delay using the metronome and recording short clicks. In case I discover the exact delay, how do I nudge my track?
Thanks again! :slight_smile:

EDIT: Additional info. I am already using ASIO4All. I also tried to reduce the buffer only for input, from 512 to something very little like 64, but I didn’t notice any improvement. Maybe I should try again combining it with the deactivation of network and antivirus.

Regardless, your bluetooth headphones will give you an unacceptable delay. Get rid of them. (no, don’t do that.). Use wired headphones. Otherwise you won’t hear things when they are playing, you’ll sing later than you should, you’ll hear a big echo from the time you sing something. What a pain in the ass.

That said, there are ways to use them, as Louis said… but you’d have to push every recorded track back in time by a certain amount… and you just simply can’t monitor yourself through Cubase, unless you like the echo effect. AND even if you monitor sounds directly through your audio interface, you’ll still hear a delay and record late.

1 Like

I see what you mean, @shagazulu . I know I can also use my headphones without bluetooth, directly wired like standard headphones. I’ve never tried but I will do it, as I understand bluetooth’s delay is not acceptable for music production. Thanks for your tip, I’ll follow it! :slight_smile:

@Louis_R I have tried all of the following together in one try:

  • set ASIO4All buffer for microphone input from 512 to 64
  • disabled network adapter from Windows’s Devices Manager
  • disabled antivirus
  • closed background applications such as Skype, Teams, etc., and kept only Cubase open
    Then, to try, I have kept only the audio track in Solo mode, turned on the metronome, and recorded myself clapping my hands in time with the metronome. The result is still a quite big delay, unluckily. :frowning:

I will start using my headphones in wired mode, to avoid further delay issues. But what can I do for input delay? Since I am currently using the notebook’s built-in mic, I don’t think bluetooth is influencing this particular delay. Am I wrong?

Thank you again for your help, very appreciated! :slight_smile: I’m a totally noob in music production.

There technically isn’t any input latency anymore. You’ve solved that problem.

And yet there’s still latency.

What’s happening is you’re hearing the audio in your headphones, you know, 40 to 100 milliseconds later than Cubase thinks you are. And so, when recording, you are simply reacting too late to the incoming audio.

In what other scenario does that occur? It doesn’t occur with wired headphones, or radio frequency headphones, or speakers. Only bluetooth headphones. It’s not input latency, it’s output latency… which is a whole other animal.

1 Like

You can nudge with the nudge buttons :

Try this PLE preset : Nudge by 1s Left.xml (6.9 KB)

Applying this preset will nudge all selected Events and Parts 1 second to the left.
I created it like this as an example but you may set your own value and override it by saving it again.

User presets are saved in a dedicated Project Logical Editor folder under: /Users/user name/Documents/Steinberg/program name/User Presets.

How to use PLE presets :

1 Like

Seems like this would be both easier & more accurate if you just put the headphones up to the mic and recorded the actual delayed metronome.

1 Like

That’s right lol. Why I didn’t think about it ? :man_facepalming: :laughing:

Probably because you could successfully tap along in time, while my taps would be more, ahh lets call it expressive.

1 Like

Hi all! :slight_smile:
Thank you very very much for all your precious help! You were right! There was no delay with recording: I had output delay with bluetooth headphones! :smiley:
Now I’m using my headphones wired with the 3.5mm jack and everything works like a charm!

Here are the screenshots of my Audio Connections for input and output:

Thanks again guys! :slight_smile:

1 Like