Delete Ending Measures

It seems simple enough to add measures at the beginning, end, and even the middle of the score. What I can’t figure out how to do is to delete measures at the end of a piece, like I added a few too many and want to get rid of the ending few empty measures. Any help would be appreciated.

To remove bars, put the caret at the position where you want to delete bars, type Shift+B, and into the popover type e.g. -4 to delete 4 bars.

thanks Daniel.
is that an interim solution? Obviously when I have pages of empty bars to delete (not an unrealistic scenario), I’ll be happy not to have to provide an exact bar number.

To delete all of the bars at the end of the flow, choose Write > Trim Flow.

Yes, that works brilliantly. Thanks so much, Daniel!

I mentioned this problem in another thread: The final system of one particular flow is filled vertically to fill the frame, but not horizontally. I’ve added a few bars and deleted them with Shift+B and a minus sign, to try and kickstart some engine. Whatever method I’ve chosen, I end up with one out of two:

• The page is not filled horisontally to the frame.
• Or there is a “tacet al fine” in all instruments of the score.

The “tacet al fine” will from what I gathered be possible to get rid of in coming updates, it was discussed in another thread. (Also the perhaps not super necessary “1” above single empty bars will be adressed. )

To make the final system reach the right-hand margin, go to the Note Spacing page of Layout Options and switch off ‘Only justify final system in flow…’.

that is fine if I want to delete them all, but not if I want more discretion over how many (empty) bars to leave in the score.

You can delete all the existing empty bars and then create the number you really want. Type +4 in the popover to create 4 empty bars, for example.

Suppose I have xxx consecutive bars to delete, but want to keep the last yy bars, that are populated. Some sort of direct “select bar” mode does seem imperative, here.

For now, at least, you would position the caret at the start of the xxx bars, type Shift+B, type -z (where z is the number of bars in xxx you want to delete), and that should leave you with what you expected.

I just love it when you answer somebody’s question, and they turn round and say, “no, the real question was something different”…

and I apologize for that, it was really meant as a further question.

I am trying to get rid of Tacet al Fine and nothing works. Tried Write-Trim flow but did not work. Please help!

Figured that out. Sorry!

Hi. I tried that but it doesn’t work for me…
I have to say that I had to change a mesure with no time signature (X) and that it changed the time signature of the subsequent bar. I manage to get the good time signature where I needed, but this undeletable bar appeared at the end. I can’t even write in it: It’ll continue to create always this one more bar. I can’t make it fit in a system either… it’s like a “wild bar”…
last bar.png
I attached the file here:
Last bar won’t delete.zip (449 KB)
Any help would be welcome :slight_smile:

Cyrdup, what a mess you’ve got yourself into! I think you’ve somehow created the penultimate barline manually, then added the 1/8 time signature, and then added a system break to your manually created barline.

  • Turn on View > Signposts > System breaks.


  • Delete the system break on the final bar.


  • Delete the 1/8 time signature.


  • Add a new 1/8 time signature where the old one was.


  • Go to Write > Trim flow

Problem solved.

P.S. What an interesting-looking score - it’s great to see what Dorico can do :slight_smile:

Thank you!!!
I don’t know my self what I did… but you saved me :slight_smile:

Dorico is such a good software. I can’t wait to see what it’ll become :slight_smile:

Same here. Any idea what the future plans for it are?