Deleting beats in last bar

Ah - I see. I had selected the global insert setting. Not the one below it. Thanks!

That page in the latest (v4) manual has been updated quite a bit to pick up (hopefully) some more of the nuance of this: you can’t delete only some of a bar this way.

In Dorico 4, you now have the option to use the “global adjustment of current bar” Insert mode scope to change the duration of a bar more easily. If my memory serves, in your context that would mean activating Insert mode (key command I so the button appears highlighted in the Notes toolbox), setting the scope to “global adjustment of current bar”, selecting two beats in that final bar, and pressing Delete (just your bog-standard delete, not Shift-B, -2q).

I’d like to revisit this. From what I can tell, when I tried to do your above suggestion nothing happens.

What I did:
Press and hold the Insert button and selected the one with the world icon.
Selected the quarter-note rest at the end of the bar that I want to delete.
Push delete.
Nothing happens.

I just saw at the bottom of the post that you linked to that it says:

  • Deleting some, but not all, beats from bars according to the prevailing time signature deletes the contents of those beats only. If you want to shorten a bar’s duration, such as at the end of flows that start with a pick-up bar, you must instead either input a time signature with the required number of beats then hide the time signature, or input a barline and delete any excess bars if necessary.

So from what I can tell, the old way is still the only way to do this.

Yes, those two ways still work, and the way Lillie described uses a new feature in 4.0.

I am on 4.0. The thing I posted as a response to Lillie is in the 4.0 documentation. So I believe that the only way to do this is still the old way of creating a time signature and hiding it.

I don’t know about all possible methods, but what I usually do is, select the rest after the last note, invoke the Bar popover with Shift-B and type “final”. This usually creates a final barline and chops off the remaining bit. If it doesn’t, I delete the hanging over bit via the system track.

1 Like

In addition to the global scope being selected, was the Insert button highlighted and therefore activated? Apologies for the obvious question but just to clarify.

I just tried this here myself, and it worked as expected: the last beat was deleted and the last bar became a 3/4 bar.

I’ll be double-checking this at updating the note in the manual accordingly in the near future.

Well clearly I’m doing something wrong. Here’s me trying it:

Insert with global scope activated:

Selecting the last note:

Pushing delete:

That’s very strange, it definitely works for me either pressing Backspace or Delete, or using the Edit > Delete menu option. I’m not sure what else to suggest except checking this is consistently the case, in all projects on your computer?