Deleting channels in mixer...

This should be so easy. I deleted tracks in the tracks view, but these empty tracks remain in the pool and the mixer. I deleted them from the pool, and they are STILL in the mixer. Right click, left click, shift delete, nothing works.
There seems to be no way to get them out of the mixer. Cubase is just too cumbersome. I love a lot of the features, but for example in Preonsus, you right click and delete. In Cubase 7 I’m sure you have some obscure way of getting rid of these tracks. After spending about an hour in the manual and googling, I cannot find a way to get rid of these tracks. Most say is it simply highlighting the track and then do shortcut shift delete. Does not work. This is crazy.

I just noticed this for the first time yesterday - have a track in the mixer that seems to be tied to the Halion SE track I added but there’s no activity there and I can’t get rid of it. It is making my eye hurt.

I have just about had it with Cubase. I’ve really tried to like it. Spent a lot of time trying to learn it. I’m only going to keep it on my computer to use the chord track, but it is going to be Presonus all the way from now on. It is just flat out more functional. The really, really weird ways of trying to do tasks in Cubase has just gotten on my nerves. Like for example dragging an instrument out into nowhereland to get rid of it. Is it really that hard to just set up software so you can right click and delete? The way you have to accomplish tasks in Cubase is just so awkward. I’ve spend a lot fo time with Sonar x3 and Presonus, and Cubase by far is the most frustrating of the three. I’m done like a done turkey.

1 Like

Select the track, Right-click on the track header and choose “remove selected track.”
I found it very helpful to watch the tutorial videos from Steinberg, as well as other on Youtube.

The track doesn’t show up in the track list. It just shows in the mixer and when you right click on it there is no option to remove the track.

Is the track “hidden”? I am referring to the visibility tab on the left of the project window by the inspector tab.

Give me a break Phil. I’ve watched tons of Cubase videos. You have to find out about all the obscure ways
getting tasks done. I am pretty much done with Cubase. It is just too annoying.
I am glad the Presonus group jumped ship. Instead of trying to find out the “secret” way of getting stuff
done it is much more intuitive. The track shows up in the inspector and in the mixer but not in the
track window. You cannot delete it from the mixer or the inspector. I’ve tried everything. For such a simple
task as deleting a track you would think it would be much more obvious. And, also, how do you delete an instrument track from the track window? I see no way to do that either. You can hide it, but how do you delete it? Crazy.

53 views and no answer. I guess there is no answer. So if you have channels you want to delete, you cannot do that. Just delete the entire project and start again and hope you don’t get any more you want to delete but cannot delete. So that way you can spend hours working on a mix and then have to delete it because you have a bunch of channels you want to delete but cannot!!! Maybe it is some sort of weird Cubase crash? Don’t know.

When you say the track shows up in the inspector but not in the track window, I am having a little trouble picturing that. A screen shot, as well as which version you are using, would be helpful.
How did you go about deleting the track? What are you dragging?

Cubase 7.5 introduced track visibility management - the ability to hide tracks. You did not say whether the track in question was “hidden”, but that seems to be the first thing I would look at. It needs to be unhidden, and then you can delete it. It IS as simple as a right click.

https://www.youtube.com/watch?v=znrSpZNqh0E
https://www.youtube.com/watch?v=6RFI13OWzT4

I am having a little trouble picturing that.

Here are jpegs of the Project Window and the Mix Console. The phantom track is the HSSE Out 2. I removed it in the project window by right clicking and removing the track. It remained in the Mix Console but there is no activity when I play the tune. I tried to back the project up in hopes that it would leave it behind but no, it stayed put.

I am using Cubase Artist 7.5.30 and this is the only time I have had this problem. I suspect I clicked something to enable the instrument track to work but I can’t remember it…
ProjectWindow.jpg
MixConsole.jpg

Is HSSE in the Instrument Rack (F11)? If so, look at 'activate outputs".

1 Like

That did it! Thanks for your help.

Absolutely. If there’s a hard way to do it - cubase will do it that way. Hide the button. Make it miniscule. Or not even have a way of doing it.

this thread is over 5 years old…

Could it be that the “tracks” in the mixer are no tracks, but input channels? I’m asking as I had a similar confusion when opening an archived project and I didn’t know anymore where those channels in the mixer came from…
If there are channels in your mixer, which are not in the track list (editor window), then you may look at your >Studio>AudioConnections (F4) setup, especially the Inputs and Outputs.
To delete inputs you do not need anymore, select them and right-click-delete.

I think I found the solution as the visibility tab in the mixer is independent from the one in the project itself. So most likely you have invincible channels in the project. Make them visible and then you can delete them as normal in the project and then the same channels will disappear in the mixer as well! Phew my OCD were running riot on me!!
The tabs are called “inspector & Visibility” in the project window and " Visibility & Zones" in the mixer window.

I found another way to do it. Bu theres still one i cant delete.
i went to “project” in top left of screen, and clicked “remove empty tracks”

wow… well done
which one you can’t delete?