Dell XPS 15 (9560) and MR816CSX

For anyone interrested the following seems to be a working setup for connecting the MR816CSX to a Dell XPS 15 via the thunderbolt port.
Need a couple of adapters, but seems to work so far.

Dell XPS 15 (thunderbolt port) -> Apple Thunderbolt 3 to thunderbolt 2 adapter -> Apple Thunderbolt to Firewire adapter -> FW800 to FW400 cable -> MR816CSX
Operatingsystem is Windows 10. OS/thunderbolt software does complain that the Apple adapters are “not made for PC use…”, but still works fine.
TOOLS for MR V1.7.8 for Windows installed.
Cubase Pro 8.0.40.
Dell XPS drivers and firmware updated to latest versions (installed this week). Windows 10 has latest patches.

One thing I noticed was that when only the TB3 to TB2 adapter is plugged in, Windows 10 does not see it as a device (absolutely nothing seems to happen). I was sure it was not working, but when plugging in the TB to FW adapter Windows sees the FW device.

PS! Wireless adapter in my Dell XPS must be disabled for this to work stable. Completely unstable with the wireless active.

No guarantee that this will work for everyone, but so far so good. I have not tried via my Dell TB16 docking. Will try later this week.
I would also like to point out that this is tested in a homestudio situation. I did run a 30 track audio project with quite a few plugins without any problems.

I have done some testing with the TB16 docking, and the Apple Thunderbolt to Firewire adapter is not working via this. Can not get Windows to detect it when it is connected via the Thunderbolt port on the dock.
I have not tested any other adapters.