Different Input and Output device.

Im trying to move back to Cubase from Logic. In logic you have a ‘logical’ drop down to choose your input device (in this case my iRig guitar input and then my output device (my laptop in built audio). No matter how i try I cannot have a different input and output device. If I choose iRig as my VST audio system then I only get the iRig in my drop downs for both input and output. Any ideas what I’m doing wrong?
Screen Shot 2014-01-11 at 16.45.13.png
Screen Shot 2014-01-11 at 16.45.31.png
Simon

Yes, this is because of the ASIO driver you have selected.
If that’s the iRig ASIO driver, then that won’t support any other in and outputs than the iRig one. Your best bet in this case is usually to install ASIO4All. That’s a free generic ASIO driver that supports multiple audio interfaces at once.
Make sure you set this driver in Cubase device setup, and use the ASIO4All control panel to set which in and outputs on your computer you want to be available in Cubase.

But of course since he is on a Mac, he can’ t use ASIO4all, but must create an “aggregate device” instead.

Oh sorry, on mac it’s aggregate device indeed.

Thanks guys, what’s an aggregate device? Also, does Logic come with a multi-in/out ASIO driver? Is that why it works from the get go?

S

What´s google…?

http://www.logic-users-group.com/forums/
http://www.logicprohelp.com/forum/

Ive searched for aggregate device for cubase as I’m fully aware of Google as I run one of the UK’s biggest search companies. Thanks. All it shows me are device specific aggregate devices such as one for mackie, one for Maudio etc… If anyone can point me in the direction of a download for an aggregate device driver for mac to get Cubase working with my iRig and/or Blackstar amp interface and my output from the laptop ot would be greatly appreciated.

S

And I dont need info on Logic, Logic works fine, straight out of the box. I’m questioning why software as established as Cubase (ive been using it since my 1040st days) doesnt have the ability to run multi in/out from the start. Whereas Logic does.

If anyone else has the same issue (which I can’t believe there isn’t) This looks like it will help.

http://www.tech-recipes.com/rx/2690/os_x_get_multiple_firewire_and_usb_asio_devices_running_together/

S

Yep, that’s it.
Cubase fully supports multiple in and outputs out of the box, as long as they’re available in the same driver.
Don’t be offended by Thinkingcap’s posts too much, he believes it’s better if people find out stuff for themselves with the right pointers. Can’t say I disagree with him, it just comes across a bit rude at times.

Don’t worry I wasn’t offended. We look after tons of forums and we encourage regular forum users to weed out people that don’t at least make some initial effort… in my case I had spent considerable time looking at it, searching for solutions, and was frustrated that Logic did what I wanted but Cubase didn’t when everything else about Cubase is amazeballs. It turns out that Core Audio doesn’t seem to be used the same in the latest version of Mac software so you have to hardwire it via the utilities function which unless you know what you’re doing isn’t easily found.

Thanks anyway, I’ll give it a go tonight…

S

I think it’ s only a small minority who feels really offended by some of my posts, and most of the time it seems it’ s really only those people who are too lazy to look up anything at all on their own.

I believe that some things have been posted more than enough on these forums, so I really don’t need/want to repeat them again and again, especially if they (IMHO of course) can be found relatively easy. And yes, there are plenty of people who can take my hints as advice, and solve their problems on their own.

Fair enough, I wasn’t criticizing you :slight_smile:

Steady on boys… By the way setting an aggregate device in the Utilities on a Mac works. I was originally looking for a ‘driver’ called an aggregate device driver. That didn’t work…

So. For anyone else wanting to run Cubase with multiple audio interfaces, you have to go into the midi audio settings in Applications/Utilities and click the + button at the bottom and add an aggregate device. It’s fairly self explanatory.