Digi003 with cubase 10

I’m hoping someone has a solution to my problem. I recently picked up a digidesign digi003 pretty cheap to try solve an outboard routing problem I had. The seller assured me that it would work with cubase 10 (I’m a sucker) but I’ve not managed to get it working properly yet.

I’m running cubase 10 with windows 10 and have an avid approved FireWire card.

This is what I’ve tried so far…

When using the latest 003 driver that is apparently is compatible with Windows 10, I get stuttered play back, clicks pops and only selected tracks being audible. This is the best I’ve had with getting it working.

I’ve tried using it through asio4all, it recognises it but does not play back audio.

I’ve tried using the V8 generic asio avid driver for non protools systems but it installs as the ‘eleven rack’ driver and cubase can’t find the 003 hardware. The v7 generic driver is not recognised by cubase.

I’ve played with buffer settings which make no difference and my pc is usually fine with a lot of loading anyway.

I’m hoping that it’s not just simply incompatible and there is a solution to this. I realise that it is designed to work with protools, but the research I did beforehand backed up the sellers opinion that there will be a way to make it work. I’m hoping I’ve just not found the way yet

Thanks in advance

Found this on the web.

#1-remember to never “hot-patch” the firewire as it can(and usually will) fry the 003 FW chip, the computer FW chip or sometimes both(learned the hard way).
#2-if the buffer is stuck, that’s a pretty sure sign of either of 2 things. A-the 003 is NOT the selected audio engine, or B-windows is using the 003 as its default playback device(go to Sound>Properties and set windows to use the on-board sound card as its default playback device).
#3-there may be more than 1 FW driver available in windows and its worth trying each. Back in windows 7, there were 3 drivers available; Legacy is what Avid recommended, but that one never worked for me(003 controller). The driver that worked for me was one named "TI Compliant.

Thanks, I’ll give these things a try and report back.

Ok, so I’ve definitely not hot patched at either end myself, and I assume as I am getting some sounds out of it, that the previous owner hadn’t either.

The 003 is definitely not the default playback device.

I am using the TI driver.

I’ve opened a few different projects and it seems the i don’t have the same issue with my master projects that only contain a few audio files and a few plugsin on the master bus, not sure what this might suggest… like I say cpu has never been an issue. Midi issue maybe?

It might be too late to reply, but here’s the solution. The only 003 driver which works with Cubase of any version is 8.0.4(beta). And it’s working as it should be on my system.(Windows 10 64bit / Cubase Pro 10.5 / Digi003 Rack)


Uninstall any other version before install this. Please note that this one is made for Windows 7, and is NOT supported officially on Windows 10. So if you try to install this, too many warning message will be popped up, just ignore them and “install it anyway.”

Hope this helps.

1 Like

your great ,thanks