Direct Monitor Gutiar Amp Classics on UR28M not working


I recently setup my new UR28m on my Windows 7 64bit box, with Cubase 8.0.20. After enabling Hardware rack within Cubase, I can see (and hear) REV-X on monitor only as designed. I can also enable the ChStrip and that works as well. But when i change from the morphing ChStrip to the Guitar Amps classics I hear no effected signal. When clicking the “e” to edit the effect, the Guitar amp interface comes up and the level (knob in the plug-in interface) moves with the setting on the Hardware channel, but no input or output signal shows in the GA plug-in interface and it does not show as powered on (the Blue “power on” button cant be turned on, though the red light on the amp interface is on).

So, I can use Direct Monitoring to get Comfort reverb and or Morhping ChStrip on incoming signal (without writing to DAW), but when switching to Guitar Amps, they don’t seem to be active in the signal path (regardless of setting the HW strip to mid or lower setting for “monitor only” or “DAW and Monitor”).

Can any one help me determine what I am missing?


Have a look at the limitations specification on PG 36 of the manual, it sounds like you might be employing too many Channel strips. You can only have one stereo or 2 mono CS in use if you also want to use an Amp emulation.

I’m having the same issue, and I’m using only one channel at a time. I’ve tried channels 1, 2 and 3. As with MGiardetti above I get signal, and effects work perfectly on everything except the amps. The amp GUIs appear, and the knobs turn. However, the input and output meters are erratic, and the amps don’t have any effect on the signal.

Just installed on this machine. Windows 10.

I had a similar issue when my UR44 was new, a firmware upgrade fixed it.