Disable automatic layout

Automatic layout of every element is a great feature in Dorico. In most cases the program does this very well.

But there are some cases where I don’t want Dorico to do any changes automatically. For example: The publisher asked me to alter the lyrics font after I had done all the layout work. When I changed from “Academico” to “Times New Roman”, every system on the page was moved by Dorico. So I had to check everything on the page.

I would prefer, if there was an option to disable the automatic layout.


PS: As a long time Finale user I never used “Automatic layout” in this program.

It’s not a 1-step process, but the next time this happens, you can lock all the frames prior to changing the font. Alternatively you can “make into staves” each line (as it is) and it will put stave breaks on each line to keep the layout from re-flowing due to the new font.

As of Dorico 1.1 you can disable automatic adjustment of staves and systems on the Vertical Spacing page of Layout Options, but you’d need to do this right at the start of the layout process and then adjust everything manually, because if you do it at the end, of course disabling the automatic adjustments will also put the staves back to their default positions, and potentially introduce collisions… and then you’d have to check (and potentially change) every staff and system gap anyway.

Changing the font used for lyrics is a pretty major change and I’m not surprised that it caused Dorico to reformat the score, incidentally.

All that above is not really want I want: I would like to be able to totally disable Dorico to do any automatic layout changes (vertical staff spacing, horiziotal note spacing, position of any other objects, …).

Sometimes at the end of my work, when I change the position of a small object (let’s say an accent >) for only only point, Dorico repositions several other objects and staffs. I feel like losing control over my work and have to check everything again.