disable f1 open help

Hi all in the title , i can’t use f1 For shortcruts because when I press f1 it’s open help windows

I saw the same problem on the forum but in the cubase 7 forum since 2013 still not fixed ?

It’s not because of mac osx preferences I am clear on this and F2 F3 ect … work’s great for shortcuts

thank’s

I saw the same problem on the forum but in the cubase 7 forum since 2013 still not fixed ?

I guess it’s “not fixed” because it’s not considered broken. It’s just how it was designed.

So it’s ridiculous ,

Do you often use the help button in session ?

f1 is just on top of the 2 most important tools we use in every sessions , it take one of the best place to place shortcuts , for … help …
it’s a joke

Once again
hurry up steinberg please

At a minimum several times a week, often daily.

Apparently your mileage varies.

anyway
ok no problem if somes people use this , but why i can’t change this key ?

I hardly ever use the help key but it does not bother me being there. This thread made me wonder and I´m not in the studio today so can´t test.
Can you change any of the F keys functions or are they all set in stone?

I guess you could use Autohotkey (on Windows) to remap the F1 key. There’s a similar piece of software for Mac but I forget the name of it right now.

You can change them all except F1. And you can even change shift+F1 (and the others too) if you want. I wonder if the reason F1 can’t be changed is because it is an MS standard for F1 to invoke help. Word, Excel, Windows Media Player, etc. all use it for help, as do non-MS applications like Photoshop & Chrome. The only thing I’ve ever seen the F1 key do is invoke help for the active window if that window has a help function (and if it doesn’t, it does nothing). I’d guess that this association is occurring within the OS and not the specific application.

Even in Cubase’s Key Command window, if you hit F1 you get a help screen.

With protools f1 don’t open help , it’s a protools normal key

Wait… you guys are saying these is no way to disable this? It’s been driving me insane, I often accidentally press it when reaching for the “1” button.

F1 is considered to be a global help key across all applications by convention. So I can understand why there is no customization.