Disabling input from a broken mod wheel?

I have a problem with my master keyboard (SL 990 Pro) and need help or ideas for a work around:

The mod wheel of the keyboard is apparently broken and is continually sending random data spikes to MIDI tracks in Cubase.

Is there any way in Cubase to completely disable mod wheel input on all MIDI tracks? These spikes are pretty annoying and the keyboard is out of warranty so I´d rather have a software side fix and use the modwheel from another device instead.

The keyboard has no setting to disable the modwheel, at least I haven´t found a way in the manual to disable it.

Personally I would fix it on the controller side, but with the MIDI filter (Prefs -> MIDI -> MIDI filter -> Controller) you can filter out CC1 (Modulation) the easiest way. Problem is, other device’s CC1’s won’t pass through either.

+1

If you’re not going to fix your SL990, and still need to use a Mod Wheel from another controller, you have to disconnect the SL, “unfilter” CC1, and record your Mod Wheel. I know that’s the hard way, but that’s the only option you got. Unless the other controller (the working one) is a keyboard (albeit with less keys) and you decide to replace it with the broken SL altogether. Your choice. :slight_smile:

Good luck.