Disabling insert plugins doesn't remove latency

When I’m playing a keyboard controller into a vst, e.g. a Halion piano, and click the monitor icon on the track, the latency is so significant that it sounds like a slapback echo, making it hard to play in time.

After some debugging, I discovered that the culprit is the three plugins I have on the stereo bus (Waves’ SSL EQ, bus compressor, L2). If I delete all plugins, the latency goes away. I have a Yamaha TF5 mixer as my audio interface (ASIO Direct Monitoring enabled) and Stereo points to channels 1 & 2. I tried routing Halion to channels 3 & 4 to bypass the Stereo bus, and that also eliminates the latency whether the plugins are inserted on Stereo or not, since Halion’s not using Stereo in that case.

But here’s the part I don’t understand. If on the Stereo bus I disable inserts altogether, or go in and disable each one of the three plugins, the latency problem remains with no changes. Only deleting the inserts altogether makes the latency disappear.

I have a workaround by routing to 3 & 4 when playing or recording a vst, but I’d like to better my understanding of what’s going on. I thought that disabling a plugin would effectively bypass it, but apparently the signal is still going through the plugin - and accumulating latency - even when disabled. Is there a basic concept I’m not understanding regarding the disabling of plugins?

You are bypassing, not disabling.
[alt] clicking the on off button in the rack will disable it. Bypassing will only bypass the audio signal flow through the plugin. The plugin itself and therefore PDC is still active.
Also read up on the „constrain delay compensation“ function.

Excellent, just the advice I was hoping for. Will remember the [alt] and engage in a little RTFM.

Thanks, man!

I’m adding this note in case it helps someone else…

I brought up a project with my standard master bus inserts, but it didn’t have the latency problem. Switched back to a different project, and it was there (like half a second or so of latency). After a little back and forth, I realized that the old project was still using Waves L3 Ultramaximizer, but I’d switched newer ones to the L2. The L2 doesn’t have any latency that I can feel. The L3’s latency makes a vst instrument unplayable without disabling plugins, constraining delay compensation, etc.

TL;DR
Waves L3 Ultramaximizer has massive latency. Use the L2 to avoid it.

Use L2 on your masterbus if you dont like snare in your mix.

Simply engage the constrain delay compensation when you are going to record, so the only latency you have is from the asio buffer.

this: ^^^^^^^^^^^^^^^^


I’m surprised other DAW’s don’t have this and it’s a simple solution to plugin latency.

engage the constrain delay compensation when you are going to record, so the only latency you have is from the asio buffer