Disappearing tempi

Since, currently, fermatas don’t hold (noticeably) in playback, I inserted some tempi changes at their locations followed by another to bring the tempo back, effectively causing a pause.
I then hid the markings i.e. metronome mark and text not shown in the properties panel and they all vanished beautifully.
Then I wanted to change the tempo of one of them but they had all vanished so completely that I couldn’t find them, neither by selecting whole bars nor through using Edit->Filter->All tempos.

Is there another way to find them again?

Turn on View > Signposts > Tempo and the tempi should become visible, as blue signposts.

It would be fair to write that fermatas do not modify playback at all (yet).
When you hide a tempo marking, there’s a signpost that appears. You probably have chosen (against your will!) to hide the signposts, but going in the View menu and ticking Show signposts should solve your issue. You can click a signpost and modify the properties associated to the hidden object (whatever it is, tempo marking, text marking, etc)
Hope this helps!
[Edit] : Leo was faster, again :wink:

Well I never - excellent and muchas gracias for both your speedy helps! (Sorry about the Spanish - just had a glass of Rioja!)