Disk Cache Usage Meter Spike !

How to fix high disk usage ? Pls show anyother cheap & reliable options than replacing a new hard drive or switching to SSD ?

Thank you guys :slight_smile:

And Happy New Year to all Cubase buddies & developer team too :wink:

I don’t think there’s much you can do without getting an extra harddrive. If you already have multiple harddrives, try splitting your sample libraries across them to reduce the load on each disk.

You didn’t specify your OS, but if you are on XP or older it might help to defragment your drive, that could help improve your read speeds a bit.

If you are on W7, try disk repair. Maybe some bad sectors need to be taken care of. I suppose the drive is out of warranty? Nowadays many drives only get one year of warranty but maybe you still have 3?

Are you just getting disk spikes? Or does the disk cache meter creep up/remain overloaded? Does it affect playback, or is it just something you observed on the performance meter (F12)?

I ask this because Cubase’s transport controls causes disk cache spikes and I don’t think there’s anything you can do about it.

If you have an (otherwise empty) project with just 1 audio track without even audiofiles loaded/recorded, the disk cache meter will briefly overload (and just as quickly disappear) when you press Play/Stop/ and all the other transport controls.

Thanks for the tips man. 365 GB sample library already on secondary drive :stuck_out_tongue: Im using Win7 Ultimate 64 bit & no need to defragment as its upto date.

Just reinstalled the OS completely as my system was really slowed down & disk cache meter was spiking really high ! After reinstallation system gets faster but still disk cache meter is spiking when i work on a project with remarkable amount of audio tracks loaded like one below. And it causes audio glitches/stutter.

http://www.youtube.com/watch?v=V6Z1BCLWLGw

Luckily i have 3 year warranty :slight_smile: But i think Dell will not replace until it completely stops working. HDD is from Western Digital.

Thanks for the reply :slight_smile:

Actually the disk cache meter shows spikes & causes audio stutter (choppy audio/audio glitches) but it dont remain overloaded. This usually happens while working with remarkable amount of audio tracks. No issue with the VST tracks.

I have no problem with a single audio track but while working on a mix CD like below i have to work with 10/30 audio tracks & thats the time when disk overload occurs.

Thanks for taking your time helping me out :slight_smile:

How much RAM have you got in your system?

I’m not sure exactly what Cubase means by ‘disk cache’ or how Cubase loads audiofiles and such when you open a project, but I’d assume Cubase tries to load as much as it can from your HDD into RAM and once your RAM is ‘full’ (as in: Cubase is unable to allocate anymore RAM for audio files), it’ll have to page out existing data from RAM and load more data from (the much slower) HDD into RAM, which can’t keep up with the project playing back, thus causing the disk spikes.

So another take on this could be insufficient RAM. Are you running 64-bit Cubase? Might be worth a shot if you aren’t already, as Cubase 32-bit on a 64-bit OS still can only allocate max 4GB memory.

My workstation has 16GB RAM (you guys can see that in my studio gears description under my every single comment) & i’m using 64 bit Cubase. Not pretty sure but Disk Cache Meter depends on hard disk’s data reading speed, so upgrading to SSD could fix this issue but its costly option as i told above. So any alternative if anyone know…

Whoops, I did look to see if you had a signature with specs, but I was looking for it in the window where you post a reply, which hides the signatures apparently. :slight_smile:

Hmm, yeah…16GB would seem enough to me. But you could check Windows Task Manager to see if it’s maxing out RAM. If so, a RAM upgrade might do the trick. But it does seem it’s most likely the HDD that’s the bottleneck. But it’s hard to say, as I don’t know exactly how much data you have going on in the project and how Cubase handles this exactly.

I can’t imagine getting an SSD for my audio HDD at this point, prices are still ridiculous! :open_mouth:

Good luck anyways!

Try the disk repair function of windows. It might take very long maybe even 24 hrs to complete. Either way things will get better or not, but if it is taking that long, it is likely that the HDD is the problem. The rest of your system specs are just fine. But a harddisk with lots of bad sectors, there is no cure for that, you should send the the drive back to your shop. Or install a spare one just to check it out.
I have had to send back a drive three times already because of spikes and audio stutter. Each time the shop returned me a refurbished one and the problem was gone (of course untill another one went bad :smiley: )

CPU & RAM usages are normal, so i dont think its a RAM issue. I’m pretty sure its a HDD issue.

Anyways thanks very much for help mate :slight_smile:

I think i gotta call Dell support & ask them for a replacement as its in warranty. Hope they co-operate.

Thanks anyway mate :slight_smile:

MY PERSONAL OPINION…

WESTERN DIGITAL HDDS are not for me ! One failed & another slowed down…

I’m using Cubase 7.5.4 and have been experiencing the disk cache problem recently. Specifically it happened after I upgraded my hard disk to a 2TB Western Digital WD20EARX SATA-III drive. I created separate partitions for samples, recording, data, etc. as I have always done with my previous drives. This drive was trouble with constant disk cache spike and audio drop-outs right from the get-go. Eventually I had to swap it out for a 500GB drive for recording and a 1TB drive for samples & data. .

Even though the 500GB and 1TB drive are older, slower [SATA-II] and lower spec vis-a-vis disk cache everything runs seamlessly. In my case having a separate partition for recording was no longer enough and only having a separate drive for recording would do… at least everything’s running smoothly now.

SO… if you’re experiencing disk cache spikes, dig out an old HD, put your projects on it and see how it goes before you give up and pull your hair out. It worked for me so there’s no reason it shouldn’t work for you.

Hi Hemansu and everyone. I think that the cache overload problem will totally disappear if you delete some (or all) stereo tracks (maybe inserted in the DAW from a stereo mixdown or a stereo recording) (if you only unmute the tracks the problem will remain). Some DAWs can’t handle right both mono and stereo audio tracks.

Hey Hemansu!! Iknow its prolly 7 years too late lol BUT!! The reason the spikes are happening is most likely due to the setting in
Studio Setup > VST Audio System > “DISK PRELOAD” is set to 2 seconds. I switched the setting to 6 seconds and the spikes stopped! :smiley:
In the HELP/manual it says:
“Disk preload is the amount of audio data that is loaded into RAM prior to starting playback. The purpose of this is to ensure smooth playback”

Hope this finds you well!

1 Like