Disk Overload Error at Export from Arranger Track

Hi all. I spent several hours getting untangled from a problem that caused me all kinds of pain and figured I’d pass along the solution to help everybody else save time (this is foreshadowing - you’ll see) in case it hits you, too.

For People with a Short Attention Span:
In short, I got the dreaded disk overload error occurred during export message and I isolated the cause to using the arranger track. I had to turn off the arranger track on my transport bar to make the problem stop. I can’t export the song following the arranger chain, but at least I can export it.

For People Who Are Morbidly Curious Or In The Throes of This Agony And Want Help:
I wanted to drop about 8 bars of a tune I’d been working on so I added an arranger track, fired up the pencil tool, drew a box on the arranger track from the start of the tune to the 1st bar I wanted to delete and another box from the end of the section’s last bar to the end of the tune. It played back perfectly but kept failing when I tried to export. I had made several other changes along the way, so it wasn’t immediately obvious that the arranger track was the problem. I read 6-8 threads on the old forum to figure out what was wrong and, based on what I’d read, tried the following things:

*) Check the ASIO meter. No problems as my machine has plenty of horsepower - the meter maxed at about 35%
*) Blow away application directory. This has solved other odd problems but didn’t help this time
*) Start taking out recently added VST plugins one at a time to see if one of them was the culprit. This was not fun
*) Changed buffer size on my interface
*) Blurted out miscellaneous incantations, curse words and pleas to nobody in particular. Felt good but didn’t help at all

Then I realized that the Left and Right locators were shifted to the left by about 8 bars as compared to where I had originally set them. I thought to my self, “Self, that number of bars is pretty close to the number skipped using the arranger track.” Self acknowledged my keen powers of observation while politely ignoring how long it took me to make this discovery. One other clue occurred to me after that fact. Namely, that a part I had recorded after I started using the arranger track kept placing the recorded part about 8 bars to the left even though I’d played it correctly.

Given the anomolies with the placement of recorded parts as well as the moving locator bars, I think Cubase doesn’t account for the jump ahead via the arranger track when putting location information into new events under this scenario. I also think think the inconsistency in location information makes it freak out and crash when doing an export, which in turn throws the disk overload error since that message is as good as any other if it’s not going to be more specific. It kind of reminds me of that scene in Back to the Future where Marty and Doc send the dog one minute into the future (I know - foreshadowing). The dog happily buzzed along without realizing anything unusual had happened but Marty and Doc were sitting around in the parking lot waiting for the car to show up again. An odd analogy? Ok, I will accept that but in fairness to me I am tired.

In any case, I hope the information above helps should you find this while searching for answers in the future. See what I did there? Another reference to time passing, and a lot did while I tried to figure this one out.


do you have this problem also when you “flatten” your “arranger track” first, and then export?



Hi Chris. I tried it and here is what happened when I flattened it:
*) Song orginally started on bar 21, but got moved to the left and renumbered to start on bar 1 after flattening
*) Left and Right locators did not follow the change, but stayed in same place (starting on bar 21)
*) I adjusted the locators so the entire tune would be exported
*) The first export resulted in a CPU Overload Error Occurred at Mixdown message about 20 seconds into tune. Note it was CPU Overload not Disk Overload after flattening
*) I tried 2 more times and it exported ok
*) Not sure why it gave a CPU Overload error the first time and not the next two because I didn’t change anything else

So, it turns out the export did eventually work with the arranger track active but it took a few tries. I also wasn’t expecting bar 21 to move left and become bar 1, but I don’t know if that is the way it is designed to work. It did lead me to a question - is there some way to insert empty bars to the front of a project?

I don’t know if this would be the situation but last week I had to mix down a project that I used the arranger with and got the disk overload message. I started the mix down again and it worked. Go figure.

It could be. It seems that the arranger track problem can be sporadic like you had and like I had after flattening the track or could be certain like I had before flattening the arranger track.

If I have “real-time-export” ticked, I have the same message but no arranger track in my project, I still trying to find out why…

Got this problem tonight rendering lass lite in kontakt. Unchecked *real time export and it worked.