Display Glitch: Polyphonic mode/Voicing for Drum staff Cubase 10.5

Hi,

I am writing a percussion of a single staff where I need to have on different drum sound to stem up and/or down on drum staff. But It seems impossible to set the voices. I have set up my own drum map and expression maps.


Is it possible to do that? Any workarounds would be appreciated.

Edit: I edited the subject after working with TheMastero on this.

There seems to be a bug here. Or a display glitch?
(by the way, why is your time signature grey? Is it selected and intentional?)

Do you mind to try it? The time signature is greyed out because project layer is turned off. That doesn’t change anything. I tried to enter drums in different voices ( turned off my drum map), couldn’t enter any notes in layers 2,3, or 4.

I had already tried, no problem here.
Could you start a new empty project and reproduce?

The issue is in Cubase 10.5. I tried in Cubase 10, it show the polyphonic staves!

BTY, What’s the use case of having drum staff in a key?

Again, no such problem here in 10.5.
Maybe an issue on Mac?
Probably a step by step procedure to reproduce could help determine.

Not sure what else I can do.
I selected Go>Library (Hold option to reveal hidden library folder)>Preferences>Cubase 10.5 Drag this folder and any previous Cubase folders to the desktop.

Here is the step by step procedure in gif: https://ibb.co/m9sb3wP

Thank you TheMaestro.

The Polyphonic window should never be empty!
I suppose there is something wrong with your Cubase configuration/installation.

I would try this first:
Start Cubase in Safe Mode
1- launch Cubase, when the splash screen appears, hold down Cmd+Shift+Alt
2- In the window that appears, check “Disable program preferences”
3- Click OK

Try the polyphonic mode

I see. that is a display glitch. In safe mode the same, result.


Is it possible to have polyphonic staff have a single staff rather than two?

Sure, turn off voices 5 to 8 under Polyphonic settings (uncheck “On” column under Properties group for those voices). If you are able to see anything of course!

Thanks for the tip. I will do that. But, I really like to fix this. I created few drum maps and wanted to try them, but it seems I always have some stability issues.

Using the preset: “Optimize for two voices” did it.

Unfortunately it does not allow you to turn off the voices.

Run Cubase in safe mode ( plugin and preferences dissabled):

  1. Convert a drum staff to polyphonic
  2. it places a grand staff with Bass clef
  3. Open the score setting and try to uncheck this voices. It’s nothing there to uncheck.

I suppose that is another bug on my side besides the display glitch, if I am not mistaken.