Dissociate quantize and length between score and key editors

I compose by entering notes into the score editor and then I adjust expression in the key editor to run sound libraries in order to make mock-ups of my scores prior to performance. If I choose a low quantize value (say an 8th note)in the score editor to make it easier to add notes without having to place them with the great precision that would be necessary if it were set to 32nd notes, then when I come to the key editor, that too is set to 8th notes, whereas the ideal setting for drawing expression curves is 32nd notes. The same is true with note length: if I enter a whole note in the score editor, the the key editor moves to that setting and I can draw only huge steps one bar long. This is extremely frustrating, as I nearly always forget (despite using Cubase for 20 years!) to reset the quantize and lengthe values before I draw in my expression curve. I would like to be able to keep my key editor settings (quantize and length) to 32nd notes, irrespective of what quantize and length values I have in the score editor. In the preferences pane under “Editors”, there is a “Link editors” box which I thought might do the trick (I want to “unlink” editors"), but leaving it unchecked doesn’t dissociate the key editor and the score editor in the way described above.

HI, as I know it’s a built-in problem as you’re not intended to start producing by entering notes into score editor, so you have two options:
1- Go for Dorico
2- Enter the notes in key editor mode using a MIDI and edit them in the score editor.

Ha ha! Thanks for your reply!
I know this may sound crazy, but I’m a classical composer and I don’t know any other way to compose than by writing notes!

For now I’d suggest you this: set key commands for Quantize Presets and Length Quantize, doing so you can change these settings quickly when you switch to Key Editor and go back to the score.
The hardest part is getting used to it.

That’s not true. I wonder how you drew that conclusion from the fact that Cubase sets the Q value globally.

What Maestro said will have to do for now, this is a common feature request, indeed. Add your input to a feature request I think there’s one in that forum.

Thanks for your replies, and sorry for not responding sooner.
Key commands might be a good workaround. Glad to hear it’s a common request. I think my original post was in a feature request section of the forum.