Distorted Sound in Template Setup (Cubase 11 Pro - VEP)

Hello there!

I’m having the weirdest kind of issue.
I’m running a Cubase Pro 11 Template with the samples being hosted in VEP (Vienna Ensemble Pro) 7 (locally). The VEP instances are situated as ‘Rack instruments’. For every library I have a folder in Cubase with the instruments I have loaded up (So I have a folder for Spirfire woodwinds with in it 15 midi channels going to the VEP Rack-instance for the piccolo, flute, oboe etc… etc…)
All of the instruments in this folder are also confined in the same VEP instance (‘tab’, if you will).

The weird thing is (and thus my problem):
When I have no channel selected in Cubase, and I manually press (so with my mouse, since a midi keyboard won’t work; read below) a note on the KONTAKT keyboard in VEP it sounds perfectly fine. But when I select the channel for that instrument and click the same note in the same instrument it sounds massively distorted. This even occurs when I select a channel in the same folder (so in the same VEP instance). Say I select the ‘flute’ channel in Cubase and I press a note on the Piccolo instrument in VEP it will still sound distorted.

I have no clue where to look for answers and it’s not a problem I’ve heard of before.
Any help would be greatly appriciated!


Once you select the track, the Record is enabled automatically by default. This mean, all data start to be processed in real time. No ASIO-Guard, no prefetch…

Could you try to increase your Audio Device Buffer Size, please?

I didn’t know why I hadn’t thought about the buffer size. I adjusted it (since it had somehow gone down from 2048 to 256) and it works perfectly now! Thank you!
I still don’t fully understand why it was happening the way it did, especially since - if the buffer was lower - then I imagine the non-selected channel should have also crackled?
Either way, it works again, thank you very much!


Because the processor didn’t have enough time to process the “real-time” data/signal (because of the low Buffer Size). But thanks to the ASIO-Guard, there was enough time to pre-process the rest.

Also, make sure you have ASIO guard turned off for VEP.